2

If you can advise or solve my problem – please answer

I trying to install CiviCRM 4.7.14 for wordpress 4.7 on windows machine, all steps of installation based on official CiviCRM installation guide. After step where i setup database connection and click install i got at left panel icon civicrm how it must be, but after click on this button I got error about non correct path in civicrm.settings.php, after fixing double slashes to single slashes “/” in this file and update page I got next error that I can’t solve

Fatal error: Uncaught CRM_Core_Exception: [0: Found installation canary. This suggests that something went wrong with tracking installation process. Please post to forum or JIRA. thrown in C:\xampp\htdocs\wp-content\plugins\civicrm\civicrm\Civi\Core\InstallationCanary.php on line 53

All requirements are fine and I do not got any warning or errors at step with install.

Thank you in advance

  • 1
    This error means something went wrong in the installation procedure. You can find more information about the Installation Canary at civicrm.stackexchange.com/questions/15594/… . Can you try to drop and recreate the databases to start with a clean slate? – Kainuk - CiviCooP Dec 13 '16 at 12:01
  • @Kainuk yes i tryed three times, and got this error three times. Wordpress installed from blank and civicrm too, did not got any problems about requirements or something, all entires green. – Anton Kukin Dec 13 '16 at 12:39
  • 1
    What version of PHP are you using (PHP 7 is still very new for CiviCRM)? – Kainuk - CiviCooP Dec 13 '16 at 13:00
  • @Kainuk PHP Version 5.6 – Anton Kukin Dec 13 '16 at 14:59
  • 1
    Sounds like a permissions issue. – Alan Dixon Dec 13 '16 at 21:16
2

I just did an installation on my Windows Laptop, and it worked. I describe below my configuration. Maybe it leads to a working configuration on your system.

  1. I downloaded and installed the xampp-win32-5.6.28-0-VC11-installer installer from ApacheFriends. The installation decides for the default home C:\xampp.
  2. After the installation, the Xampp control panel starts. I start Apache and MySQL.
  3. I open the shell to create the databases (I am more at my ease with Unix). I create the databases with the following commands:

    mysql -u root
    
    create database wp character set utf8;
    create database civi character set utf8;
    grant all on wp.* to wpuser@localhost identified by 'wppwd';
    grant all on civi.* to civiuser@localhost identified by 'civipwd';
    flush privileges;
    
  4. I install WordPress by unzipping the download in the C:\xampp\htdocs directory. I remove all other files (to keep the installation clean).

  5. I do the WordPress configuration according to the documentation. (database wp, user wpuser, password wppassword).

  6. I unzip the CiviCRM (civicrm-4.7.14-wordpress.zip) in the directory C:\xampp\htdocs\wp-content\plugins.

  7. Now I activate the CiviCRM in the plugins menu and complete the installation with the Almost Ready invitation. (database civi, user civiuser, password civipwd).

  8. Installation completes without problems.

The civicrm.settings.php file is generated in the directory C:\xampp\htdocs\wp-content\uploads\civicrm. In the file is a mix of forward slashes and backslashes, but CiviCRM does not seem to bother. For example:

$civicrm_root = 'C:\\xampp\\htdocs/wp-content/plugins\\civicrm\\civicrm\\';
if (!defined('CIVICRM_TEMPLATE_COMPILEDIR')) {
 define( 'CIVICRM_TEMPLATE_COMPILEDIR', 'C:\\xampp\\htdocs/wp-content/uploads\\civicrm\\templates_c\\');
}
  • for me it return Fatal error: Uncaught exception 'Symfony\Component\Filesystem\Exception\IOException' with message 'Cannot rename "D:\home\site\wwwroot\wp-content\uploads\civicrm\templates_c\Cac1698.tmp" to "D:\home\site\wwwroot/wp-content/uploads\civicrm\templates_c\/CachedCiviContainer.408b9887eb68e85cf1131bc6d5ded777.php" – Anton Kukin Dec 14 '16 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.