2

Updrading from CiviCRM 4.6.4 to latest (4.7) and using wordpress 4.4.5..

The upgrade process showed no errors, in fact it showed "Done" and began to redirect to a url that never loaded. I clicked on "Civicrm" on the left sidebar of wordpress and nothing. I went to the base url of the wp install and this message appears:

Sorry but we are not able to provide this at the moment. Unknown extension: nz.co.fuzion.payflowlink Return to home page.

Found this in /wp-content/plugins/files/civicrm/ConfigAndLog Dec 16 10:59:28 [info] $Fatal Error Details = array(3) { ["message"]=> string(43) "Unknown extension: nz.co.fuzion.payflowlink" ["code"]=> NULL ["exception"]=> object(CRM_Extension_Exception_MissingException)#978 (10) { ["errorData":"CRM_Core_Exception":private]=> array(1) { ["error_code"]=> int(0) } ["cause":protected]=> NULL ["_trace":"PEAR_Exception":private]=> NULL ["message":protected]=> string(43) "Unknown extension: nz.co.fuzion.payflowlink" ["string":"Exception":private]=> string(0) "" ["code":protected]=> int(0) ["file":protected]=> string(104) "/Users/me/Sites/donate_new/wp-content/plugins/civicrm/civicrm/CRM/Extension/Container/Collection.php" ["line":protected]=> int(150) ["trace":"Exception":private]=> array(30) { [0]=> array(6) { ["file"]=> string(104) "/Users/me/Sites/donate_new/wp-content/plugins/civicrm/civicrm/CRM/Extension/Container/Collection.php" ["line"]=> int(111) ["function"]=> string(12) "getContainer" ["class"]=> string(34) "CRM_Extension_Container_Collection" ["type"]=> string(2) "->" ["args"]=> array(1) { [0]=> string(24) "nz.co.fuzion.payflowlink" } }

  • 1
    Is PayFlow a wordpress extension or a CiviCRM extension? CMS CiviCRM extensions need to be turned off before upgrading. – Christia Dec 16 '16 at 18:30
  • @Christia That's good to know! I was following a civi guide that makes no mention of extensions: wiki.civicrm.org/confluence/display/CRMDOC/… I will try doing an upgrade again but with extensions turned off. – user4089 Dec 16 '16 at 18:44
  • 2
    @Christia After turning off the extensions and deleting that extension, the upgrade went through normally. That's not to say I have new issues lol. Thanks! – user4089 Dec 16 '16 at 21:48
  • Great! I posted this as an answer so others can benefit also. – Christia Dec 16 '16 at 23:19
1

Turn off contributed CiviCRM extensions, (such as PayFlow) before upgrading. Then turn them back on or reinstall them.

From the guide, "Because of the huge number and ever-changing nature of community contributed Wordpress plugins, CiviCRM cannot guarantee compatibility with contributed plugins. A list of know incompatibilities can be found at WordPress plugins/themes incompatible with CiviCRM." Check the compatibility list.

https://wiki.civicrm.org/confluence/display/CRMDOC/Installing+CiviCRM+for+WordPress

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.