2

I responded to a question re: using Let's Encrypt SSL certs at this comment. I now need to go in the other direction because I made a mirror of our live site on my laptop in an xampp environment (win 10). There I don't have, nor do I want to use, an SSL certificate.

First, I removed the https redirect in .htaccess. Then, I was able to "simply" deactivate the Really Simple SSL plugin by following https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible. This made our local Wordpress site work and I could also get into the back-end. However, CiviCRM does not work from either the back-end or front-facing pages. From the back-end, it generates an error trying to bring up the CiviCRM dashboard. Both give the same error: "Parse error: syntax error, unexpected end of file in C:\vhost\sdbikecoalition\wp-content\uploads\civicrm\civicrm.settings.php on line 450"

[edit] And, of course, I checked the civicrm.settings.php file and found nothing suspicious [/edit]

I suspect it is because, on our live SSL site, I went to Administer > System Settings > Resource URLs and checked Yes on "Force Secure URLs (SSL)". Is there somewhere I can change this by just directly editing a record in the CiviCRM MySQL database?

I suspect that will solve my issue as that was the only thing I did within CiviCRM that was specific to SSL.

4

Verify the file which is being reported as having a syntax error. PHP has a syntax check mode with -l (for "lint").

php.exe -l C:\vhost\sdbikecoalition\wp-content\uploads\civicrm\civicrm.settings.php

If civicrm.settings.php is not valid PHP, CiviCRM will not function - SSL or no SSL.

Note that your local PHP install may differ in version and therefore syntax from the PHP installed on your server.

  • Chris - Thank you for your observation. I was barking up the wrong tree. When I edited the BASEURL, I fat-fingered a right bracket } into the trash. Once fixed, I received an error indicating I had forgotten to also change civicrm_root to my local directory and then I was up and running! I then could get into CiviCRM > Administer > System Settings > Resource URLs and set "Force Secure URLs (SSL)" to No. Before I did that, there was a proper warning that https was not set up on this machine, but it wasn't the killer I thought. Again, MANY THANKS! – Karl Rudnick Dec 24 '16 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.