3

I recently made a mirror on my laptop running XAMPP. Wordpress 4.6.1 + CiviCRM 4.7.14. Everything works fine on the front-facing site and everything seems to work fine in the back-end, except the dashboard that comes up. There is a message in the default image in the screenshot below that says "The requested page "/welcome?prot=1&ver=4.7.14&uf=WordPress&sid=66b480f3fa29fea3920454ef21065ed5&lang=en_US&co=1228" could not be found." Note that I also upgraded the Wordpress to 4.7 which is one of the reasons I created the local version - to uncover some upgrade issues that I resolved. The CiviCRM dashboard issue was there prior to the upgrade as well. I can easily restart with backups of our LIVE site where everything, including CiviCRM dashboard, is in good shape.

Anyone have an idea how to fix this? Thanks in advance...

Screenshot of CiviCRM Home dashboard

  • Did you try taking that item out of your dashboard and then putting it back later? It might not be available anymore. – Christia Dec 28 '16 at 10:48
  • That was what I tried to do at first. If I click on "Configure Your Data" or "Refresh Dashboard Data" nothing happens, so there's no way to even select what the CiviCRM dashboard should look like. And, btw, we pretty much use the default provided with CiviCRM although we show a top Membership report. Is there a way to edit the database to affect what we see on the Dashboard since that page is completely non-functional now? Anyway, as far as I can tell, that is the ONLY thing that is broken, but you never know. One thing breaks and there may be some other lost, hidden functionality. – Karl Rudnick Dec 28 '16 at 16:20
  • I should add that under Civi > Adminster > System Status, all is Green, except of course cron as I really don't want to run cron or mailings on the local testbed anyway. – Karl Rudnick Dec 28 '16 at 16:35
  • But you can click the "x" in the corner of the report to remove it from the dashboard. Does that work? – Christia Dec 28 '16 at 17:56
  • I had never done that before and it worked. Thanks for that suggestion! but clicking on "Configure Your Dashboard" still doesn't do anything - although I cannot view the whole screen to see if there's anything else. That looks like a possible symptom with our custom theme, which I can look into later. I was planning to let this go, but I'll also snoop around in php error logs. Any other ideas? I forgot to mention that our apache httpd for this Windows instance listens on port 8080 (80 is taken by my WIndows System). I hope there are no CiviCRM port dependencies. – Karl Rudnick Dec 28 '16 at 23:04
2

Did you change the various URLs/paths in civicrm.settings.php and wp-config.php to match the new location?

See this section from How should I copy a site from production to staging? :

  • Replace all the usernames, passwords, paths, etc. in settings.php, civicrm.settings.php, and/or wp-config.php with the values appropriate to the staging server. If using git, these files are ignored in git, only local copies exist.
  • There are a number of values we override in civicrm.settings.php on the staging server to use the appropriate paths...
  • Yes, of course, or else the site wouldn't work at all. It's just the CiviCRM dashboard. I thought that the sid=66b480f3fa29fea3920454ef21065ed5 reference in the error message was maybe somehow encoded to point to the physical site where it was installed. I can perform all the 4.7.14 upgrade steps on the new localhost. Did I miss something? There is no settings.php in the civicrm paths. I only edited wp-config.php and civicrm.settings.php as you pointed out. – Karl Rudnick Dec 24 '16 at 23:02
  • Ah, I missed this statement in your question: "The CiviCRM dashboard issue was there prior to the upgrade as well." So, to be clear, the issue presented itself when you went from live server to local, not just after the upgrade to 4.7? – Allen Hutchison Dec 24 '16 at 23:08
  • 1
    Correct - it was not a Wordpress 4.7 update issue. I wasn't concerned, because no functionality is lost, as the dashboard is just an overview, but I would like it to work as it did before I copied from my live server to local. Also, it's Christmas Eve, so not to worry. I'll revisit after Christmas. Thanks for looking into it. Now relax and forget about it ;) – Karl Rudnick Dec 25 '16 at 1:07
  • Thinking the hosed dashboard issue was just a result of the site copy from live to local, I backed up my civicrm database and then dropped ALL tables, deactivated and deleted the CiviCRM plugin. Saved away my wp-contents/uploads/civicrm/ext that contained extensions we added. Ensured the civicrm/ folder was removed from wp-content/plugins (not there by deleting the plugin) or wp-contents/uploads (had to do manually). Then did a clean install of CiviCRM 4.7.14 into Wordpress 4.7 per regular instructions. – Karl Rudnick Dec 25 '16 at 23:07
  • After the install (and before moving extension over and restoring the database), the dashboard was STILL hosed per the screenshot in my question and it had exactly the SAME "The requested page "/welcome?prot=1&ver=4.7.14&uf=WordPress&sid=66b480f3fa29fea3920454ef21065ed5&lang=en_US&co=1228" could not be found." message in what it could display. That makes me think that the sid may be tied to my Wordpress copy. Any clues? This is also hosted on xampp on a Windows 10 laptop. Perhaps a firewall issue trying to access civicrm.org or similar? – Karl Rudnick Dec 25 '16 at 23:10
2

I'm going to provide one answer for the moment. This appears to be a Windows-only issue. I lifted my wordpress file hierarchy to my linux laptop and set permissions accordingly (chmod 775 all directories, chmod 664 all files, chmod 660 wp-config.php and civicrm.settings.php). Running linux xampp, the CiviCRM Dashboard appears exactly as it does on the live server.

Since it's Windows-only and our server and my second laptop run linux and all is OK, I'm willing to let this go. Also, I tested with Windows Defender and Firewall completely OFF, so that's not the issue. Linux is finicky [perhaps I should say "precise" which I actually prefer] with permissions, and there still could be a permission issue on win 10 as I simply inflated the tar.gz backup from our host to my win laptop. I find it easy to set permissions on unix in a directory hierarchy - see fix-wordpress-permissions.sh. I'm not so good with scripts like that on windows, being a long-time (30+yrs) unix person.

I hope this post at least may be useful to someone else. Moral is, at least for me, stick to linux!

1

Well, this is embarassing as the answer was simply to clear all browser cache AND cookies. I had only cleared the browser cache before and just last night cleared the cookies for something else. When I brought up my local win Wordpress+CiviCRM under xampp, the CiviCRM dashboard was back in business! I apologize to those who took the time to help diagnose, but thank you for doing so. I'll add a cookies tag to this post ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.