3

After upgrading to 4.7.0 on Drupal 7.50, the link to the CiviDiscount administration in the CiviCRM navigation menu is incorrect (cividiscount_reset_1); see screenshot below.

enter image description here

I have attempted to edit the URL by going to Administer > Customize Data and Screens > Navigation Menu. When I open the link to edit it, it reports the wrong information entirely and notice that the info seems to be from the link above it; see screenshots below.

enter image description here

enter image description here

In keeping with the formatting of the other links, which start at civicrm/, I edited the link to include the proper URL to the CiviDiscount administration page. I tested this link independently (full URL) in a browser and made sure that it works: /civicrm/cividiscount?reset=1. When I save the edit, it shows the same "all reports" that it was before, in the screenshot above. I created a new link in the menu, but it goes to http://civicrm/cividiscount?reset=1 which obviously doesn't work. When I put in the full URL, https://dev.example.com/civicrm/cividiscount?reset=1, the URL that it goes to is actually cividiscount_reset_1, the original incorrect link from the beginning.

Considerations:

  • all other links in the menu look normal, without the underscores and work
  • the correct URL for CiviDiscount works when entered manually
  • CiviDiscount appears to be functioning normal
  • I am running CiviDiscount version 2.6
  • I have done some investigating and realized that this version of CiviDiscount is not compatible with CiviCRM 4.7 version. I will upgrade it and see if that fixed the problem. – Christia Dec 29 '16 at 22:59
  • Thanks for trying to help me Christia, but my permissions are fine, and I am running v 3.3 of cividiscount and it is not working in my wordpress site. – Gregory Heller Feb 9 '17 at 18:01
2

The problem was resolved once I upgraded the extension to 3.3 and corrected the permissions for the extensions folder for the group. chmod -R 775 sites/default/files/civicrm/ext. After the CiviCRM upgrade, the extensions directory changed so permissions needed to be reset also.

  • 1
    Make sure to mark this as the correct answer. :) – Allen Hutchison Jan 2 '17 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.