1

My issue is related to this post by @John, I think.

I recently upgraded from 4.6.XX to 4.7.14. I had beautiful formatted email templates that I use regularly. I am trying to use my template now in 4.7.14, and it strips all the HTML formatting, such as background color, font type, font color, etc. from the email. When I try to save it, all the formatting disappears.

I've set Administer > Customize Data and Screens > Display Preferences > Configure CKEditor > CiviMail tab > Advanced options > Set fullPage = true as an option, per @Coleman. But that has not fixed my issue.

What am I missing?

  • This question: civicrm.stackexchange.com/questions/15330/… makes me think that maybe you're using TinyMCE and not CKEditor for template editing. Can you check **Administer » Customize Data and Screens » Display Preferences" and update your question to confirm the WYSIWYG editor that's set? – Jon G - Megaphone Tech Jan 5 '17 at 19:16
  • I saw that thread, thanks. When I go to Administer > Customize Data and Screens > Display Preferences, I have two WYSIWYG editor options to choose from: CKEditor and Textarea. I am using CKEditor. – Michelle Rojas Jan 5 '17 at 19:31
  • Update, I think that perhaps this has to do with the functionalities that are enabled in my CKEditor. When I use the UI, I don't see the Advanced tab for Table Properties. So evidently, I don't have all the functionalities enabled. I didn't customize CKEditor when I installed it, and it was working fine before I upgraded CiviCRM to 4.7... – Michelle Rojas Jan 5 '17 at 19:37
  • And I am in Joomla. – Michelle Rojas Jan 5 '17 at 20:10
  • We had the same problem and solved this. Our solution is here: civicrm.stackexchange.com/questions/17355/… – Davy Ivins Mar 1 '17 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.