2

Warning: Smarty error: problem creating directory 'C:/domains' in C:\domains\xxx.be\subdomeinen\wordpress\wwwroot\wp-content\plugins\civicrm\civicrm\packages\Smarty\Smarty.class.php on line 1094

Warning: include(C:\domains\xxx.be\subdomeinen\wordpress\wwwroot/wp-content/uploads\civicrm\templates_c\en_US\%%E6\E65\E656EDCD%%wordpress.tpl.php): failed to open stream: No such file or directory in C:\domains\xxx.be\subdomeinen\wordpress\wwwroot\wp-content\plugins\civicrm\civicrm\packages\Smarty\Smarty.class.php on line 1264

Warning: include(C:\domains\x.be\subdomeinen\wordpress\wwwroot/wp-content/uploads\civicrm\templates_c\en_US\%%E6\E65\E656EDCD%%wordpress.tpl.php): failed to open stream: No such file or directory in C:\domains\xxx.be\subdomeinen\wordpress\wwwroot\wp-content\plugins\civicrm\civicrm\packages\Smarty\Smarty.class.php on line 1264

can't find sollution; Any ideas?

  • 1
    c:\ indicates a local hard drive to me - is that what you are trying to do, install on a local machine? – Barbara Forbes-Lyons Jan 5 '17 at 23:09
  • No, I use a hosting provider. I started with a fresh wordpress (4.7) and civicrm (CiviCRM 4.7.15). Didn't change anything – DirkVanRoy Jan 6 '17 at 12:07
1

This really looks like you're trying to install on a hosting provider, but you downloaded the WordPress package for Windows. I can see how this might have happened given the WP site, but it's not at all what you wanted.

Which hosting provider are you using? Do they offer WHM/cPanel? Or Plesk? These are management frameworks for hosting providers. Inside them you should find something like Softaculous - this will do the WordPress install for you. Once your domain has the minimal WP in place, you'd do the following.

  1. confirm you can reach your VPS using the ssh protocol. You will use ssh for remote management tasks and scp (secure copy) to move files back and forth.

  2. Download the Civi zip file.

  3. scp (using WinSCP or similar) the file to the default location for user root - that's the manager account.

  4. ssh into the system, change to the WP plugins directory, and unpack the Civi zip file. This might vary depending on the system you're on, but here is how we'd do it on the cloud provider I manage:

    ssh root@brandnewwpsystem.com
    cd ~/wp-content/plugins unzip
    /root/civicrm-4.7.19-wordpress.zip

  5. Log into WordPress, you should have a Civi tab at the upper left. Depending on the layout you might have to manually configure the MySQL database.

This is a five minute task for someone who's done it a few times. Do not hesitate to ask more questions if you get stuck.

0

The issue is that your paths use backslashes in some places and forward slashes in others. Windows uses backslashes; Linux and Mac OSX use forward slashes.

Because this is a fresh installation, this is likely to be a bug - similar bugs have crept in from time to time. However, I'm a bit mystified how that could be the case, because the code in question (<civicrmroot>/packages/Smarty/internals/core.create_dir_structure.php) concerns itself precisely with the issue of handling slashes correctly. I don't have a Windows machine on which to test the installation, so I'm afraid I can't be of further assistance.

  • I found a soluton ; changed the Smarty.php $this->use_sub_dirs = TRUE; to $this->use_sub_dirs = FALSE; – DirkVanRoy Jan 6 '17 at 18:11
  • not sure everything will work; Can anyone confirm this is a valid solution? – DirkVanRoy Jan 6 '17 at 18:12
  • doesn't work; get errors; tried other version, but keep getting the same error; can please someone help? – DirkVanRoy Jan 6 '17 at 22:51
  • @DirkVanRoy The vast majority of Civi installs are on *nix systems and thus folks are unqualiified to help; can you say a bit more about what you're trying to do that requires Windows? Maybe we can suggest alternatives. – Jon G - Megaphone Tech Jan 7 '17 at 22:10
0

fwiw I am facing a similar issue without the additional backslash question, ie I don't get anything like

Warning: Smarty error: problem creating directory 'C:/domains'...

Civicrm is showing as active in plugins, but I get warnings and a fatal when trying to get to the Civicrm home page in wordpress. First one is below (...wp-content/uploads/civicrm/templates_c/en_US is an empty folder)

Warning: include(/volume1/web/wordpress/wp-content/uploads/civicrm/templates_c/en_US//%%40/40D/40D353E1%%fatal.tpl.php): failed to open stream: No such file or directory in /volume1/web/wordpress/wp-content/plugins/civicrm/civicrm/packages/Smarty/Smarty.class.php on line 1270

It then lists all the include paths

(include_path='.:/volume1/web/wordpress/wp-content/plugins/civicrm/civicrm:/volume1/web/wordpress/wp-content/plugins/civicrm/civicrm/packages:...

followed by a fatal

Fatal error: Uncaught CRM_Core_Exception: [0: Transaction integrity error: Expected to find active frame thrown in /volume1/web/wordpress/wp-content/plugins/civicrm/civicrm/Civi/Core/Transaction/Manager.php on line 107

Wordpress 4.9.8, Civicrm 5.6.1

  • Welcome to StackExchange! You have posted this as an answer but it doesn't appear to answer the original question. You are unlikely to get any responses here so if you need help I suggest you post this as a new question. – William Mortada Nov 9 '18 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.