i have finally set up my Checksum for profile update. However when link is clicked inside email i am getting this message- "This profile is configured for contact type 'Individual'. It cannot be used to edit contacts of other types. If I disable the Fist Name and Last Name fields for that profile it works.

Is there a way around this as i really need to have a First Name Last Name.

  • What 'types' of contacts are you trying to edit?
    – petednz - fuzion
    Commented Jan 10, 2017 at 20:53

2 Answers 2


I'm not sure which CMS you are using but, per the civicrm wiki page, the URL Checksum for standard Profiles (edit mode) is as below:

To send people to a profile use this path where N is the ID of the Profile you want to send them to:

Drupal: http://www.myorganization.org/civicrm/profile/edit?reset=1&gid=N&{contact.checksum}&id={contact.contact_id}
Joomla!: http://www.myorganization.org/index.php?option=com_civicrm&task=civicrm/profile/edit&reset=1&gid=N&{contact.checksum}&id={contact.contact_id}
WordPress: http://www.myorganization.org/?page=CiviCRM&q=civicrm/profile/edit&reset=1&gid=N&{contact.checksum}&id={contact.contact_id}

Hope this helps and solves your problem.

  • I'm using wordpress. When I use example from wiki it does not open. So far the URL I listen above is the only one that opens so far
    – user4150
    Commented Jan 9, 2017 at 3:17

Are you sure you are sending your test email to an individual contact? if you have several contacts that have the same email address (eg [email protected]) that you associated both to your organisation and yourself, civimail might send it to the organisation instead of the individual.

take the id of the contact and view its record and double check it's an Individual.

  • set to individual
    – user4150
    Commented Jan 9, 2017 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.