1

I have created profile forms, using custom fields, which open up perfectly in create mode but when I test the forms I get this error once I hit save:

Sorry but we are not able to provide this at the moment. DB Error: no such field Return to home page.

Any ideas of how to solve this?

Here is a link to one of the forms in question: http://skillsguru.web.za/civicrm/?page=CiviCRM&q=civicrm/profile/create&gid=21&reset=1

The detailed debugging report is here.

  • may be easier to help you if you can add a quick example on one of the demo sites. – petednz - fuzion Jan 10 '17 at 20:31
  • note that Demo sites get rebuilt every 24 hours - hopefully your efforts will last long enough for someone to take a look before it gets wiped – petednz - fuzion Jan 10 '17 at 20:32
  • It would also be helpful if you could edit your question to include the version of CiviCRM and the CMS you are using (e.g. WordPress, Drupal or Joomla). – William Mortada Jan 11 '17 at 18:41
1

Based on the error in the debug message, the problem field is this one: civicrm_value_developing_an_accredited_course_5.provide_instructions_on_any_furt_119

I can't find it now, but there was a bug report recently that discussed problems with very long custom field names. Please find your custom field with an ID of 119 and see if the form works when it's removed (or at least see if the MySQL error changes). Consider recreating those fields with shorter names - you can always display them with the longer "names" in the profile's field label.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.