2

I've been getting 404s on public pages due to my directory setup, so I changed the default Resource URL in Administer >> System Settings >> Resource URLs from the default ([civicrm.files]?) to the URL for my civi directory.

I now can't get back to reset it to the default.

I've tried overriding the Resource URL in settings.php to:

http://mysite.org/mysite/wp-content/plugins/civicrm/civicrm/

but that doesnt work.

Any advice appreciated.

2

If I understand your question correctly, you are asking how to return the settings back to default.

I believe that the default settings for WordPress (in Administer >> System Settings >> Resource URLs) are as follows:

  • CiviCRM Resource URL: [civicrm.root]/
  • Image Upload URL: [civicrm.files]/persist/contribute/
  • Custom CSS URL: (blank)
  • Extension Resource URL: [civicrm.files]/ext/

You would typically only need to override the Resource URL in civicrm.settings.php if you have moved your site. I suggest that you set this back to how it was previously.

You may want to post a separate question about the problems you are having with 404s if this is still an issue.

  • Thanks for the response. To change the Resource URL back to the default, would I just change the entry in settings.php to [civicrm.root]/ ? Or do it need to change it elsewhere? – Cowcross Jan 12 '17 at 14:44
  • I've updated the answer to clarify that these settings are for the user interface (Administer >> System Settings >> Resource URLs). I suggest that you change your civicrm.settings.php file back to what you had previously. I believe this setting is an override that you have added in, so you should just be able to remove it to get back to where you were before. – William Mortada Jan 12 '17 at 16:19
  • Thanks both. William, unfortunately I'm unable to access the user interface to make the changes. Karin, I've tried your recommendation, but without much luck. I think for now I'll just do a fresh install and take it from there. – Cowcross Jan 12 '17 at 16:24
  • @Cowcross are you unable to access the CiviCRM user interface at all? If so, I think that you may have made other changes to the civicrm.settings.php file. Do you have a backup of the previous working version of this file? If so, I would suggest that you restore that version. – William Mortada Jan 12 '17 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.