1

We're on 4.6.8 and having an issue where when saving an activity which is assigned to a contact the following error is displayed:

Sorry but we are not able to provide this at the moment.

Sorry an Error Occured MysqlColumnNameOrAlias is not a recognised (camel cased) data type.

If it is not assigned to anyone there is no error. However, if you click back and go into the record again the activity has in fact been saved. Not a massive issue as the activity is saved but it's not good from a usability perspective.

From looking online it looks like the following code is where the error is being generated from:

https://github.com/civicrm/civicrm-core/blob/master/CRM/Utils/Type.php

Any ideas what is causing this?

  • This is a good question! To solve your problem, we'll need to see the expanded debugging information. In CiviCRM, please go to Administer menu > System Settings > Debugging and Error Handling, select "Yes" to both "Enable Debugging" and "Display Backtrace", and press "Save". Repeat the problem that caused your error, and you'll see much a much more detailed error. Please update this question with the expanded error and backtrace - and don't forget to disable debugging/backtrace when you're done! – Jon G - Megaphone Tech Jan 13 '17 at 12:09
  • could you double check on your CRM/Utils/Type.php if the MysqlColumnNameOrAlias is there too? – Xavier Jan 13 '17 at 12:40
1

Ah, you have the answer in your question. If you look at your reference to the current code, it should be recognizing that MysqlColumnNameOrAlias instead of generating the error in the default clause of the switch.

So I checked the history of that file, and the MysqlColumnNameOrAlias case was only added mid-last year.

Conclusion - upgrade your Civi to the latest 4.6 (which you should do anyway because of security reasons).

  • Ah that makes sense as I thought it was handled by that code. We're looking to upgrade to 4.7 soon so that will resolve. Thanks to you and everyone else who responded! – Lawrence Welsby Jan 23 '17 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.