1

All our event registration pages have stopped working in 4.7.14 & 4.7.15

Error is: You do not have permission to access this page. I've checked all Joomla ACLs for the public group and everything that needs access does and it worked ok before.

In the Logs I see this:

.../administrator/components/com_civicrm/civicrm/CRM/Event/Form/Registration.php(243): CRM_Core_Error::fatal("You do not have permission to access this page.") ...

And that file around line 243 has this:

  // check for ability to add contributions of type
  if ($isMonetary
    && CRM_Financial_BAO_FinancialType::isACLFinancialTypeStatus()
    && !CRM_Core_Permission::check('add contributions of type ' . CRM_Contribute_PseudoConstant::financialType($this->_values['event']['financial_type_id']))
  ) {
    CRM_Core_Error::fatal(ts('You do not have permission to access this page.'));
  }

I have checked the financial type records on the events and I've also checked the new minimum amounts in the price sets etc..

I can't work out why this would be failing.

Has anyone seen this or knows if there is a bug in 4.7.14/15?

Cheers,

Dave

  • The Joomla demo civicrm site seems to work fine. See joomla.demo.civicrm.org/index.php/component/civicrm/… . Maybe you can look into its configuration to see if you can find a difference. – Kainuk - CiviCooP Jan 14 '17 at 18:11
  • Thanks, I did go to check there but it was no longer linked from the main site - thought it had gone. Further to my original post, I've created a fresh install of both Joomla 3 and Civicrm latest and yes it works ok. I've compared the permissions for the public group and all was fine. If I log in as super user to the front end it works ok. IF I give full ACL permissions to a new group and login with that level of access it still doesn't work. I'm trying to suss out where this is failing, is it permissions on profiles/extra fields or something about this install on this domain, any thoughts? – Dave Jan 16 '17 at 10:07
  • I've also replaced all civicrm files in the account and that has not helped, all caches and templates_c cleared etc.. too. – Dave Jan 16 '17 at 10:11
  • What was the latest working version? I see that in version 4.7.5 the permissions for financial types were added. See issues.civicrm.org/jira/browse/CRM-16526 – Kainuk - CiviCooP Jan 16 '17 at 10:40
  • more info, I think this is related to financial types and price sets. I wonder if in a recent upgrade some permissions and new functionality has been added, If I log in as an administrator then I open an event and look at the fees tab the financial type field is blank and the price sets are blank. It looks like no-one except superadmins can see the financials type (Event Fees) and price sets. – Dave Jan 16 '17 at 11:32
1

OK, found out what this was. There is a new check box in CiviContribute Components Settings 'Enable Access Control by Financial Type' In the users system this was checked. I don't know whether an administrator accidentally ticked that without knowing what it did or whether an update process ticked it.

Anyway, this being ticked with no civi ACL obviously locked everyone out of being able to access the financial types and therefore broke the front-end event registration process.

Un-check that field and save and the system is fine once again.

Hope this helps anyone else in this situation.

(PS - it looks like super users within Joomla are somehow treated differently which threw me initially the normal civi ACL checks obviously don;t apply to Super Users - hmm)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.