1

I schedule a job through mailings. The Cron job looks like it picks it up, and the mailing is marked as running, but it never gets sent out until someone manually runs scheduled jobs (administer>system>scheduled jobs).
The process is running every 15 minutes on schedule, the jobs logs, has two entries at the time it should pick up the scheduled job. The first just has the time/date and
Summary Starting scheduled jobs execution the second has the date/time the jo Entity: Job Action: process_mailing Summary Starting execution of test job schedled - Details Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;} Full message: Starting execution of test job schedled but once it picks up a scheduled job it never completes, it will just generating the starting execution message. Also as a result of this I get the system message that Cron is not running after a bit. I've tried Civihosting support and they said to post it here.

  • Aidan, Thank you! It was an out of memory issue. When I went to run the cron job manually from cpanel, the error appeared. I contacted the hosting support, they increased the memory, problem solved! – user4225 Jan 27 '17 at 13:46
1

Is there any output from the cron job? (On Civihosting, you can configure the cron job to mail you the output.) If it is starting but not completing, it could be running out of memory.

  • Thank you, Aidan, It was a memory problem, when I ran the cron from control panel - got the memory limit error, but then it disappeared, after contacting support they increased memory and now the scheduled jobs run. – user4225 Jan 26 '17 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.