0

I have a fresh CiviCRM install on my test server and the frontend is displaying incorrectly as if it can't read the CSS Here is a test event: http://node01.tmdhosting983.com/~agsmca/index.php?option=com_civicrm&task=civicrm/event/info&reset=1&id=1

I can't seem to find the problem, is my Joomla theme overriding it?

RESOLVED

So it turns out that I was missing a whole folder on my server. The zipped civicrm folder in the installation files under the admin folder didn't install properly (even though my PHP has zip enabled and CiviCRM was installed by a professional and reinstalled by a professional).

The solution is to take manually unzip civicrm.zip from the asmin folder in the install folder you used to install CiviCRM, then manually upload these into your Joomla folder/components/com_civicrm in a new folder named "civicrm"

Here is a screenshot of the resolved page: event info screenshot

  • glad you sorted it. you could post your outcome as an Answer and accept it yourself. – petednz - fuzion Jan 27 '17 at 22:40
1

That page doesn't look unreasonable, but I'm attaching a screenshot here that shows a lot of failed css loads in the console.

I'd guess it's a file permissions issue (i.e. your server is unable to read those resources).

enter image description here

  • Thanks for pointing this out. None of the files being reference in these errors exists on my server, and I tried a fresh install and am getting the same error. I'm noticing that they are all the files that were in the civicrm.zip file contained in the Administrator folder on the install file. I'm considering trying to just upload those manually to where they are looking for them. – John Hampton Jan 27 '17 at 15:51
  • Don't do that - it'll be a configuration setting that tells civicrm where it should be looking for these files. For me it's at a path like this: /civicrm/admin/setting/url?reset=1, yours will looks similar. You can also set it in the civicrm.settings.php file if you're good with editing that file. – Alan Dixon Jan 27 '17 at 20:33
  • Shoot, I already uploaded the manually and it seemed to fix the problem. Will these cause me headaches down the line? – John Hampton Jan 28 '17 at 22:23
  • Only when it comes to upgrading your civicrm, which you should do at least a few times a year (i.e. when a security update comes out). – Alan Dixon Jan 30 '17 at 16:47
0

So it turns out that either my civicrm.settings.php file had the wrong path, or I was missing a whole folder on my server.

I manually unzipped civicrm.zip from the admin folder in the install folder I used to install CiviCRM, then manually upload these into my Joomla folder/components/com_civicrm in a new folder named "civicrm"

BUT

Alan Dixon in the thread above mentioned that this may have to manually be redone every upgrade, so a better fix would have been to edit the path in my civicrm.settings.php file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.