0

The site was moved to a different server and updated from a 4.2.7 version to 4.7.15 and everything seemed to be working but every report we try to open just keeps giving this error: https://www.screencast.com/t/Lf589LhvhP and if I add a dashlet on the backend this shows up: https://www.screencast.com/t/aWMsujgz I've been looking everywhere if there is any other setting that might be causing this to happen but no luck, and this is the only log I get when I try to open the reports:

administrator/?option=com_civicrm&task=civicrm/report/instance/41&reset=1" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"

If anyone knows what might be happening let me know.

Thank you.

  • you have a ConfigAndLog folder it should contain an error log file which will have more information. – Robin Fenwick Jan 26 '17 at 21:05
  • 1
    Have you cleared caches after moving? – Laryn - CEDC.org Jan 26 '17 at 22:58
1

If you moved CiviCRM to a different server, make sure you follow the instructions in section #9 here: https://wiki.civicrm.org/confluence/display/CRMDOC/Moving+an+Existing+Installation+to+a+New+Server+or+Location.

Delete the following files:

Important Note: Please make an off-site backup of the following before you delete them, incase something goes wrong, such as incase you delete the wrong directory or in case you would still like to look at the log files.

Drupal:

  • <drupal-root>/sites/default/files/civicrm/templates_c/* i.e. everything inside templates_c, not the directory itself (cached versions of Smarty templates that will be rebuilt)
  • /sites/default/files/civicrm/ConfigAndLog/Config.IDS.ini
  • /sites/default/files/civicrm/ConfigAndLog/* (Everything inside this directory; You can clear all the logs if you get an error about parsing XML)
  • /cache/* (Everything inside this directory. Only if you get errors after clearing the caches via the GUI) (See http:///civicrm/admin/setting/path?reset=1 for location of custom extension folder)

Joomla:

  • /media/civicrm/templates_c/* (everything inside templates_c)
  • /media/civicrm//civicrm/ConfigAndLog/Config.IDS.ini Be Careful If you have edited the IDS ini file to add any custom exclusions then you need to edit the settings for the three paths in the file, filter_path, tmp_path, HTML_Purifier_Cache.

If these paths are not accessible Civi pages will display blank.

Wordpress:

  • /wp-content/plugins/files/civicrm/templates_c/* (everything inside templates_c)
  • /wp-content/plugins/files/civicrm/ConfigAndLog/Config.IDS.ini

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.