1

I have recently enabled Drupal CiviCRM Webform Integration and it's working, however, when I view the webform components (Webform > From components) for a form that I have enabled CiviCRM processing, I get the following error. I can view other webform settings. If nothing else, I'm just trying either eliminate other webform elements and change the section name from "contact 1".

Fatal error: Cannot redeclare _webform_components_form_rows() (previously declared in /var/www/html/example/docroot/sites/all/modules/contrib/webform/includes/webform.components.inc:223) in /var/www/html/example/docroot/sites/all/modules/contrib/webform_civicrm/webform_civicrm_admin.inc on line 1506

I am using Drupal 7.50 with CiviCRM 4.7.15 and Webform 7.x-4.14, CiviCRM Webform 7.x-3.5

  • What versions of CiviCRM, Webform, and Webform-CiviCRM are you using? – Laryn - CEDC.org Feb 1 '17 at 19:33
  • 1
    Oops, I forgot to add that and you solved my problem just by mentioning it. Want to post the answer? – Christia Feb 1 '17 at 19:52
  • 1
    No it's fine -- just don't forget to come back and mark the answer below as accepted when it allows you to. :) Glad it's solved. – Laryn - CEDC.org Feb 2 '17 at 17:39
2

I didn't upgrade webform_civicrm, the Webform CiviCRM integration module to the latest and compatible version. Once I updated the module, the problem went away.

https://www.drupal.org/project/webform_civicrm

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.