0

I have just created a donate form via Civi. Tried to donate (after logging in as account holder) and completed first from ok. DOB in correct format of

27-09-64 (selected from the pop calendar)

On clicking Confirm Payment the page asking

Please verify the information below carefully

showns - However that is where it has altered the format to

DOB 09/27/1964

and on clicking Continue I get

Please correct the following errors in the form fields below: Please select Date of Birth

Can someone tell me how to solve please?

Joomla 3.6.5 - Civicrm 4.7.14

  • Thanks for the reply - cannot see reference to uk - screenshot awesomescreenshot.com/image/2154069/… – Andy Goodall Feb 9 '17 at 16:17
  • firstly - tx Andy for that pointer - i have updated as you outline. Still does not work but I noticed that when I set my date of both in the calendar it shows 27-09-1964 - when i click confirm payment it shows as 27/09/1964. Is this the cause and how do i solve? the first date format i have toi selct from a calendar to choose date - no option to select forward slash – Andy Goodall Feb 9 '17 at 16:28
  • I changed the Date Format to dd-mm-yyyy but a profile I have still used dd/mm/yyy. This was because the definition of the date in the custom field set was dd/mm/yyyy. When I changed this custom field fomat to dd-mm-yyyy then the profile changed - so this overrode the Date Format setting. You should be able to fix the problem by getting these 2 settings to agree. – Andy Clark Feb 9 '17 at 17:42
  • Ok, tx for your patience - I have had no luck yet - these are the 2 screens I have been working on awesomescreenshot.com/image/2155431/… awesomescreenshot.com/image/2155433/… awesomescreenshot.com/image/2155444/… These are the settings - I have tried various settings for birth but no effect. Is there a third area of CiviCrm I should be looking at? – Andy Goodall Feb 9 '17 at 22:05
  • When you say that you created a donate form in Civi, how did you do it? See this issues.civicrm.org/jira/browse/CRM-19490 - looks likely – Andy Clark Feb 9 '17 at 22:15
1

Have you formatted the date in Administer/Localization/Date Formats? For the UK 'Complete Date' is set to '%B %E, %Y', and 'Complete Date and Time' is set to '%E%f %B, %Y %l:%M %P'. Also 'Date Input Fields' is set to 'dd/mm/yyyy' which is probably the critical one in this case.

  • Have updated my comments -any more suggestions? this is def the right area – Andy Goodall Feb 9 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.