1

How do I set mailings to allow all tags? I'm using the latest D7 and Civi and have tried setting this via the GUI, but the editor still filters the code :-(

Below is the generated crm-ckeditor-civimail.js file (in files/civicrm/persist.):

/**
 * CKEditor config file auto-generated by CiviCRM (2017-02-13 20:10:38).
 *
 * Note: This file will be overwritten if settings are modified at:
 * @link http://ir.association.works/civicrm/admin/ckeditor
 */
CKEDITOR.editorConfig = function( config ) {
    config.toolbarGroups = [
        { name: 'document', groups: [ 'mode', 'document', 'doctools' ] },
        { name: 'clipboard', groups: [ 'clipboard', 'undo' ] },
        { name: 'editing', groups: [ 'find', 'selection', 'spellchecker', 'editing' ] },
        { name: 'forms', groups: [ 'forms' ] },
        '/',
        { name: 'basicstyles', groups: [ 'basicstyles', 'cleanup' ] },
        { name: 'paragraph', groups: [ 'list', 'indent', 'blocks', 'align', 'bidi', 'paragraph' ] },
        { name: 'links', groups: [ 'links' ] },
        { name: 'insert', groups: [ 'insert' ] },
        '/',
        { name: 'styles', groups: [ 'styles' ] },
        { name: 'colors', groups: [ 'colors' ] },
        { name: 'tools', groups: [ 'tools' ] },
        { name: 'others', groups: [ 'others' ] },
        { name: 'about', groups: [ 'about' ] }
    ];

    config.skin = "moono";

    config.allowedContent = true;
}; 
  • The following doc leads me to believe your config.allowedContent = true; is actually disabling the ckeditor filter: docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-allowedContent . Perhaps there is also another filter civiMail is employing on save? It's also pretty likely in my experience that the email clients you're mailing will strip tags that fall outside of these defaults anyways... so i'd check on that first if you haven't already. – Eli Lisseck Feb 14 '17 at 16:12
  • Hi Eli - that's exactly what I need (to disable the filter) so that no tags get stripped. But that's not what is happening. The Civi sandbox demo has config.allowedContent = true; and that works as expected. But on my sites it refuses to play along. I'm running on an Aegir setup and have asked my host to see if they can figure it out. Perhaps its a glitch with Aegir – Davy Ivins Feb 15 '17 at 19:40
  • After some investigation by my Aegir hosting provider it seems the problem may be related to the multisite file structure. I'll report back if we find a fix. – Davy Ivins Feb 17 '17 at 12:48
1

UPDATE: A fix for multisites and Aegir setups will come out in CiviCRM 4.7.21. See https://issues.civicrm.org/jira/browse/CRM-19303

After much work we managed to solve this. It was definitely a multisite / Aegir issue.

We had to go through some hoops and down some rabbit holes but you can find our solution detailed here: Solved: Is this a bug - [civicrm.files] variable

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.