0

Just updated to CiviCRM 4.6.26 from 4.6.x. Using iATS 1.5.3. Using D7. The user does not experience a completed transaction even though the transaction is complete through iATS and shows complete on user record (and in iATS dashboard in civi). The submit or "make contribution" link appears to hang up. No confirmation is sent to user or administrator. This results in the user attempting to resubmit. Any solutions? Any troubleshooting tips?

BTW: we have changed no configurations on contribution/registration pages. Previously working. But now they all hang up, we get no confirmation or "success" notification on any of our pages.

This has been resolved here: iATS Scheduled job for recurring payments does not "finish" in the logs. How can I fix this or troubleshoot further?

1

The answer is that I'm not sure why this is no longer working for you.

  • All our 4.6 sites have been upgraded to 4.6.26 and are using iATS 1.5.3 and I've had no reports of anything breaking.
  • I've just confirmed myself by making a donation to one of our projects that I get to the Thank you page.

There is a bit of Javascript on that Make Contribution button. Ask your developer/support to open up a Firebug/Console to start the hunt as to what may be going on with your Contribution page.

From your Comments I see DOMPDF is throwing an error -> it is known to blow up at times - best to disable PDF creation for your receipt. It's one of those obscure settings under Misc -> civicrm/admin/setting/misc?reset=1 -> hit No on Attach PDF copy to receipts.

  • Thanks Karin. I believe we updated from 4.6.19? Not sure. I'll try to check that by looking at the archives. In any case, it appears to be a timeout issue: Fatal error: Allowed memory size of 367001600 bytes exhausted (tried to allocate 130968 bytes) in /home/lifechallengesem/public_html/data/sites/all/modules/civicrm/vendor/dompdf/dompdf/src/Css/Style.php on line 774 – John Richardson Feb 14 '17 at 17:54
  • BTW: the recurring payments are not updating the next scheduled payment field in the tables either. So recurring payments are not completing in a way that prevents them from being triggered again. I have to go into the table to update the next scheduled. – John Richardson Feb 14 '17 at 17:56
  • Pretty sure it has nothing to do with the button. Memory allocation problem? Even so, don't know why a transaction would now exceed any memory limits, since nothing has changed regarding memory limits. – John Richardson Feb 14 '17 at 17:58
  • One more note: In troubleshooting, I did disable and then re-enable 1.5.3 just to be sure everything was re-engaged after update to 4.6.26. Still no luck. Transaction times out but shows up in iATS Payments Admin and User Record (and obviously, in the iATS server). – John Richardson Feb 14 '17 at 18:09
  • Hmmm...what could cause that last step in the process to time out like that? – John Richardson Feb 14 '17 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.