1

I'm having trouble with creating a Mailchimp webhook and I'm unfamiliar with how to troubleshoot this any further. (I've also posted this question to the Extension's Github)

The API key and callback info is correct but when attempting to create the webhook Mailchimp says,

We couldn't verify the URL is working. Please double check and try again. HTTP Code: 500

In using web-sniffer I get the following result:

Connect to 198.27.70.84 on port 443 ... ok

GET /tbe/civicrm?page=CiviCRM&q=civicrm%2Fmailchimp%2Fwebhook&reset=1&key=kasfBgoASBcb HTTP/1.1[CRLF]
Host: yourshulbythesea.org[CRLF]
Connection: close[CRLF]
User-Agent: Web-sniffer/1.1.0 (+http://web-sniffer.net/)[CRLF]
Accept-Encoding: gzip[CRLF]
Accept-Charset: ISO-8859-1,UTF-8;q=0.7,*;q=0.7[CRLF]
Cache-Control: no-cache[CRLF]
Accept-Language: de,en;q=0.7,en-us;q=0.3[CRLF]
Referer: http://web-sniffer.net/[CRLF]

The site's webhook URL and details:

Any idea how to troubleshoot this further?

3

Check whether 'allow webhook posts' permission is granted to anonymous role (go to CiviCRM's Administer menu » Users and Permissions » Permissions (Access Control), then click on WordPress Access Control).

enter image description here

0

How do you "allow webhook posts" for Anonymous Users in Wordpress?

I'm using User Role Editor in Wordpress, but can't see an option like that. I've tried "Access civiCRM" and "Create Posts" but they don't make a difference.

  • 1
    Due to the Q&A nature of Stack Exchange (civicrm.stackexchange.com/tour), this makes more sense as a comment than an answer, and I'm going to recommend you delete it. That said, it's a good question - so I've updated Kajan's answer with clearer instructions and a screenshot of what to look for. – Jon G - Megaphone Tech Aug 22 '17 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.