2

I am making a donation page in wordpress using civicrm (latest version for wordpress). For someone who comes to the page for the first time I would like to give them the option of signing up for a newsletter.

The issue is that at this stage they have not signed up yet so they are not in the database. I have a profile attached to the bottom of the donation page to allow them to put in their details. Another issue with the search bar is it allow you to find anyones email address just by searching for their name which is also not what I want.

I was wondering how to remove this search bar asking to select someone else. I would prefer for it to go to an anonymous form that doesn't let you search for contacts. See picture below of the yellow bar containing the form.

enter image description here

  • Welcome to StackExchange! This is a good question but you could improve it by including the actual versions numbers of CiviCRM and WordPress. This will help people answer the question. – William Mortada Feb 22 '17 at 12:35
3

I have a fully working donation page set up in civicrm where:

  • there is a Financial Type "Donations" set up in Administer/civicontribute/financial type.
  • Financial Type is set up in the relevant Contribution Page as "Donations".
  • A Profile is attached to the contribution page that collects information in fields such as first name, last name and email address

The settings in the profile are set to 'Used For' standalone form or directory. 'Search views' are switched off. Advance settings include "Wordpress User account required".

I assume that you have a log in facility set up in the CMS Wordpress and that you have switched on 'Anyone can register' in Wordpress/Settings/General. When a user completes your form, they should then get registered in both Wordpress and CiviCRM.

You may be seeing the Search Bar only because you are personally logged in as Admin. Try looking at the contribution page when not logged in and see what shows.

Hope this helps!

1

The answer peterb gives is correct. One other possible reason you're seeing this is because the URL you're using has "&cid=0" at the end, which is a special parameter meant to cause the behavior you're seeing. Try removing that parameter if it exists AND accessing the page while not logged in; that should fix you up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.