1

Angular installed CiviVolunteer 4.6-2.2.1 Installed Civi Version 4.6

This is my first attempt at getting this to do anything and I'm failing miserably

  1. I click on the New Volunteer Project -- I don't get the setup screen. I get a empty Drupal Page with the title CiviVolunteer (and this site is refusing to let me upload my screenshot) I also get an error "PI permission check failed for VolunteerUtil/getbeneficiaries call; insufficient permission: require edit own volunteer projects" when I try to create a new volunteer project (I have full administrator priviledges for both Drupal and CiviCRM, so this makes little sense)

  2. I also tried setting up and event, and there was no check box to enable CiviVolunteer

1

welcome to the civiverse!

Try clearing caches and setting your extension path and resource url. Those are the most common source of error regarding extensions.

If that doesn't work post back!

  • It did not work. I am an administrator, but I don't seem to have the necessary permission. Nor does anyone else. I also used Cleanup Caches and Update Paths – Ecotypes Mar 9 '17 at 0:37
  • Actually, maybe. It never occurred to me that an administrator would not automatically have permissions. But I had permission to give myself permission. So, probably working. – Ecotypes Mar 9 '17 at 0:54
1

Check all the permissions that begin with "CiviVolunteer:". Make sure that as Admin you have permission granted for all of them.

0

I'm getting the same error on a plain, clean install of CIVICRM on Drupal. The error seems to be related to the Angular component shipped with CIVICRM.

Basically the extension fails to display content for New Volunteer Project, or Manage Volunteer Project. See image below.

Fails to display content for New Volunteer Project, or Manage Volunteer Project

I have cleared cache and verified extensions directory ([civicrm.files]/ext/). See image below.

Resource URL / Extensions Directory

The extensions are downloaded via the web interface on the proper, default directory. Not enough reputation to post image. But they are in: - /var/www/vhosts/drupal7/sites/default/files/civicrm/ext/org.civicrm.angularprofiles - /var/www/vhosts/drupal7/sites/default/files/civicrm/ext/org.civicrm.volunteer

My test server config details: - Drupal core 7.56 - civicrm 7.x-4.7.22 - mysql 14.14 Distrib 5.7.18, for Linux (x86_64) - Ubuntu 16.04.2 LTS - PHP 7.0.18-0ubuntu0.16.04.1 (cli) ( NTS ) (php-fpm7.0) - Zend Engine v3.0.0, with Zend OPcache v7.0.18-0ubuntu0.16.04.1 - Angular Profiles (org.civicrm.angularprofiles) v4.6-1.0.2 2016-06-20 - CiviVolunteer (org.civicrm.volunteer) v4.6-2.2.1 2016-12-06

Can't post output of Javascript Debug Console because Stack Exchange swears it's spam. But the errors there refer to: Cannot read property 'crmAutosave' of undefined and angular.js:2133 Uncaught Error: [$injector:nomod] Module 'crmCxn' is not available! and /sites/all/modules/civicrm/bower_components/angular/angular.js?ot59kn:68:12, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.