5

Vers. 4.7.16. When I go to create a new activity in the WP user interface, the choices in the Activity Type dropdown are limited to 4 options. I want to create more activity types and when I go to Activity Types under Administer, I see lots of existing Types. How do I indicate which of these types (or a new type I create) appear in that New Activity form's activity type dropdown?

2

Certain activity types are reserved by the system for certain purposes. You cannot directly create an "Inbound Email" activity, for example, because those are created by the email processor in CiviCRM.

You can add new activity types by going to Administer -> Customize Data & Screens -> Activity Types in the menu.

1

I think this may be a bug. There should be an option on the Add Activity or the Edit Activity dialogue box that allows you to assign the the Activity to a Civi Component. But that option is not showing in my WP site or in the online demo. Documentation

DemoSite

  • Hi @CarlMiller, thx for response. Not exactly what I was asking about but you bring up a good point - I don't have a field to indicate which component a new activity belongs to. I should probably add that as a bug. – Ruth D Mar 19 '17 at 7:08
  • My question is about Activity Type drop-down fields. When I create a new activity by clicking Contact, New Activity from the menu, I see 5 activity types to choose from (4 from core system and one I created). Alternately, when I go to create a new activity from within a Contact record, I see 6 activity types (the same 5 plus a Print Doc option). But when I look at all available contact types by clicking Administer, Customize Data and Screens, Activity Types, I see 19 options, with 3 of them not "reserved". So how did only those 5 or 6 options end up in the drop-downs? – Ruth D Mar 19 '17 at 7:37
  • The way to add more of the 19 to be available with the other 5 in the drop down is via the missing Component selection New/Edit GUI. It is the answer to your original question. – Iowa Boy Mar 20 '17 at 18:46
  • I recently updated to Civi 4.7.17 and i still have the same problem – Iowa Boy Mar 20 '17 at 18:55
  • OK, Carl - thx. Is this already listed as a bug? – Ruth D Mar 20 '17 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.