0

On one of the CiviCRM sites I've set up, it keeps logging me out every 30 minutes or so. I have set the cookies in the default.settings.php file so that I'm logged out when I close the browser but it's exactly the same as my other sites, where there's no problem. Same hosting as well. Any ideas why it's throwing me out all the time??

I'm on Drupal 7.53 and CiviCRM 4.7.16.

EDIT: This is still ongoing, I've restored all settings across the site that I can think of that may trigger an issue. Just today, I've had the following error message (usually it just logs you out with no warning) but I thought it may throw some light on the issue?

enter image description here

And this is my cookie session settings in the default.settings.php file:

enter image description here

----- THE FOLLOWING ISSUE HAS BEEN RESOLVED SO CAN BE IGNORED -------

Also, same site, different issue. I've done word replacement and changed the name from Organization to Organisation but when I search for Contact Type, it's still showing Organization - regardless of whether I specify exact match or not for the word replacement?

  • 1
    any chance you are being flipped from http to https - not sure why that would log you out but one of those oddities in civicrm.settings.php that surprises folk – petednz - fuzion Mar 3 '17 at 20:20
  • also just for SE purposes, best to keep each question to its own thread ;-) – petednz - fuzion Mar 7 '17 at 3:42
  • I know - did think that but was being lazy... Promise to separate questions next time :) – Rose Lanigan Mar 7 '17 at 21:38
0

Check to see if Drupal module automated logout is installed. I would recommmend it instead of what you're doing with cookie settings - you can specify to logout after x minutes of inactivity and set that x per role.

Yes word replacement indeed does not work to override 'organization' -> what you need to do is use locale language setting (settings localization) instead.

  • I went through the Drupal permissions with a fine tooth comb, comparing to a similar site, and the site with a problem had two extra ticks: 'CiviCRM Contact Reference Field' and 'Administration Development Tools'. The latter one is linked to a Drupal module and used for debugging so I'm wondering if that is the culprit? – Rose Lanigan Mar 6 '17 at 19:59
1

I've solved the problem with the name change:

  • I used the word replacements function.
  • When you check 'Administer > Contact Types' it looks like the 3rd Contact Type has changed...
  • BUT you still need to 'Edit' and specifically change it
  • Hey Rose - and did that stick for you? I mean when you go back to the Administer -> Contact Types -> do you still see Organisation? – KarinG - Semper IT Mar 6 '17 at 20:30
  • Yes, that's fixed it permanently now. Hadn't noticed before that both needed changing - probably did it the other way round last time and changed the contact type first, and then the word replacement. – Rose Lanigan Mar 7 '17 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.