1

I have created an Event in CiviCRM and it all worsk fine in the Administrator side of Joomla when I test the Online Registration page. I have a price set of various ticket prices and the total adds up to the values as you would expect.

When I go the Registration(Live) page (i.e. the front end of Joomla) there is no Total Price text box, and the none of CiviCRM resources seem to load. The browser console is full of 404 Not Found errors for the CiviCRM scripts. On checking the path on the console the browser is trying to load the scripts from "/components/com_civicrm/civicrm/" instead of "administrator/components/com_civicrm/civicrm/".

This is a fresh install on CiviCRM 4.7.17 on Joomla 3.6.5.

What have I missed in the setup to get the CiviCRM resource loading from the Joomla frontend?

1

I found that on Joomla the default value for CiviCRM Resource URL (on Administer > System Settings > Resource URLs), which is [civicrm.root], doesn't work. For me, using a relative path for CiviCRM Resource URL does work:

administrator/components/com_civicrm/civicrm/

See also the answers to this question and the work being done by Coleman, but that patch didn't work on Joomla when I tried it.

EDIT: As of 4.7.17, the default setting of [civicrm.root] appears to work properly now.

  • Using the relative path above worked. Also note that clicking the 'Reset Paths' button (on Administer > System Settings > Cleanup Caches and Update Paths ) puts CiviCRM Resource URL back to [civicrm.root] – AshLock - Alltraders Mar 22 '17 at 23:36
  • I had the bright idea to change my URLs to the variables (Civi 5.5.1). Resources would not load on the front end. Changed the Resource URL back to administrator/components/com_civicrm/civicrm/, and it is back to normal. So there still seems to be a problem with this. – Phil Morice Brubaker Dec 14 '18 at 18:23
0

I don't have enough experience to add this as a comment yet, but wanted to point out that you could also go to ~joomla for Joomla specific help with CiviCRM issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.