0

Civi 4.7.17 WordPress 4.7.3 iATS Payments Processor

We recently upgraded from 4.6.26 to 4.7.17, since the upgrade this quirk has popped up. When making an ACH contribution, one of the required fields is Account Type and our two choices are Checking or Savings. This field displays with the drop-downs on initial load. However, once you select Electronic Funds Transfer, the Account Type field disappears. When you hit Confirm Contribution, you get an error telling you "you skipped a required field." This time the Field is displayed adn you can complete the donation. I have attached several screenshots.

I tried changing the default to Credit Card but you get the same results. I tried switching my theme to see if it was a theme conflict, but I get the same results. I also used the Chrome Inspector adn found that it is not a CSS issue. It is missing HTML so likely a php issue. I could not get the demo site to display an ACH payment option to test it there.

Is this a Civi core problem or an iATS Extension problem? Who generates the contribution form? Any ideas on what I can do to correct the issue? enter image description here


enter image description here


enter image description here

0

Please note that the xml file specifies that iATS 1.5.3 is compatible with CiviCRM 4.6. You must use 1.6.x with CiviCRM 4.7.

  • Hi Carl - can you please accept as answer so that we don't have this question automatically reposting to the still open questions page? Thanks! – KarinG - Semper IT Jul 28 '17 at 13:24
0

We recently upgraded the iATS Payments extension to 1.6 and the problem went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.