0

Using Webform to register Event Participants, how can I get the Partipant Fee (and any other amount part) displayed as a Contribution Item of the "Total" in the Contribution page, like here-under (copied from Webform Event Fees in Combination) ? enter image description here

1
  • Step1 on the post you referenced will expose the Participant Fee field to the webform List item
  • Step2 sets the amount for it

The lineitems are automatic from there on. I have webform_civicrms that add on a Contribution (Donation amount) as well as a Membership!

[UPDATED] - posting some additional screenshots: I hope this will help you!

  1. End Result: enter image description here

  2. The Start page looks like: enter image description here

  3. Note that the Membership and the Event Participant webform fields live on the Start page; the Donation one lives on the Payment page.

  4. Start page - webform Elements:

Membership -> I decided to present all live options - that means it will take the Membership Fee as specified in the CiviCRM Membership Type settings; enter image description here

Event -> two pairs: _participant_event_id form key and _participant_fee_amount form key / one pair for each event - I've set these fields to hidden -> and I've specified a $ amount -> then when someone selects the event -> the fee is added automatically. enter image description here

  • Thank you Karin for your quick answer. But I do tick "Participant Fee" in the CIVICRM Event Registration tab ; I fix its value in the WEBFORM tab (step 2) ; then Participant Fee appears in the View Webform, just like any other field, but not in the payment item list : I have to manually copy its value into the "Contribution Amount" for the payment. FYI, I use a Contribution Page which is based upon Stripe payment processor. – Jacques-Marie Moranne Apr 2 '17 at 7:57
  • Let me posted you some more screenshots - to see if you can spot differences w/ your webform config. If you want to rule out Stripe as a cause - you can install the iATS extension and use test88/test88 (agent code and password) - out of the box without signing up for iATS; – KarinG - Semper IT Apr 2 '17 at 13:31
  • Thanks again a lot Karin : your screenshots are very clear. My test is much simpler than that : only one participant, to a predefined Event. I have configured "Participant Fee" in different ways (in the WEBFORM tab) : hidden or not, fixed value or user defined : it never appears in the payment item list. BTW, I am running Civi 4.7.16 : I cannot install iATS for version compatibility reasons. I wonder if it is not a regression bug : I think I remember having this working in a previous Civi version (but not sure !) – Jacques-Marie Moranne Apr 3 '17 at 9:57
1

I have to apologize : I used a contribution page which was based upon a payment processor which is not compatible with a webform online payment.

With a Stripe payement processor, everything works all-right.

0

I'm having the exact same problem. I've got the participant fee activated and set with pricing. But, when you test the form and go to payment, it doesn't show the embedded box with the chosen participant fee. Running 4.7.16. Is there a setting I'm missing? Just wondering if you figured this out Jacques-Marie?

Thanks,

Dina

  • Hi Dina, Is your contribution page based upon a payment processor which enables on-line payment (such as Stripe) ? (this was the source of my problem) – Jacques-Marie Moranne Apr 18 '17 at 15:51
0

I've got the answer. You have to use a contribution page along with the event registration page for the box with the amounts to appear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.