3

I have just installed CiviRules 1.12 on CiviCRM 4.7.14. I tried to create a few simple test rules, but none of them worked. I suspect I might have to look for solution somewhere else.

Trigger: Contribution is changed 
Linked Condition: Contact in group TEST
Linked Action: Remove contact from group: TEST

enter image description here

I also tried a few similar Rules, e.g.:

  • IF Contribution is added THEN remove from Group.
  • IF Tag is added THEN remove from Group.
  • IF contact is removed from group THEN display the Message.

All were set to run IMMEDIATELY without delay.

What might have gone wrong? Something with setup or configuration? I did not see anything unusual.


UPDATE:

Upon further tests the issue was narrowed down to a single CiviRules action, namely, Remove contact from group.

4

I would as a test forget about the display message first, and start only with adding to and removing from group. I would expect those to work.

I have just tested a rule on my CiviCRM 4.7.15 local install as in the screen print that I have attached, and that works fine? Can you test with the same rule?

enter image description here

  • After a series of tests, I can conclude that I was missing the refresh button. Actions like Add Tag, Remove Tag, Add to Group, Display Message work fine, however, there is a problem with the Remove contact from Group Action. – Aivars Apr 26 '17 at 17:05
  • 1
    Created new issue github.com/CiviCooP/org.civicoop.civirules/issues/144. I will try to have a look in the next few days. – ErikH - CiviCooP Apr 26 '17 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.