1

I am a newbie to CiviCRM. I have installed CiviCRM 4.7.18 on WordPress4.7.4 and it failed.

The db password for CiviCRM and wp admin password does not contain any special character.

Everything on installation page was green with green checks.

After I pressed "check requirements and install", I did see successful installation message then the page redirects to

/wp-admin/?page=CiviCRM&q=civicrm&reset=1

And I see the following:

CiviCRM Home

System Status: Error

Cron Not Running

Configure Default Mailbox

Complete Setup

View details and manage alerts

Configure Your Dashboard Refresh Dashboard Data

Welcome to your Home Dashboard

Your dashboard provides a one-screen view of the data that's most important to you. Graphical or tabular data is pulled from the reports you select, and is displayed in 'dashlets' (sections of the dashboard).

Access Keys:

Powered by CiviCRM 4.7.18. CiviCRM is openly available under the GNU AGPL License.

Download CiviCRM. View issues and report bugs. Online documentation."

Using my backup I made before installing CiviCrm I have tried again this time I changed permission for civicrm and files folder to 777 from 755, thought that was the problem.

Create the /wp-content/plugins/files/ directory and ensure it is writable. CiviCRM uses this directory for temporary and uploaded files. (Source: https://wiki.civicrm.org/confluence/display/CRMDOC/Installing+CiviCRM+for+WordPress#InstallingCiviCRMforWordPress-2.WordPressInstalled)

Since I have a backup I can restore to and also delete and re-create sql db/user, I do not mind going at it again, but I think I might be missing something and it's better to know what and try again with the possible solution.

Any help/suggestion is appreciated.

Thanks,

Usman

  • This might actually be a successful installation, but the post-install messages have led you to think it's failed. Do you see the CiviCRM UI at this point? If it looks broken also, adding a screenshot to your question might help. Otherwise head on over to chat.civicrm.org/civicrm/channels/user-support and ask there, someone may be able to guide you. – Chris Burgess Apr 23 '17 at 0:17
  • I can click on CivicCRm but dashboard does not load, please see the screenshot here: masjidusman.ca/wp-content/uploads/2017/04/CiviCRM_Home.png – Usman Apr 24 '17 at 1:07
  • OK, that looks broken to me. I don't have any suggestions based on the information here sorry, though I might try swapping your WP theme to a default one to see if that fixes it ... Next steps would be to search this site for questions that describe similar problems, try and follow debugging advice already on this same site, reach out for community support via chat above, or contract a developer who can help you. – Chris Burgess Apr 24 '17 at 1:15
  • I am having the exact same issue, and can't seem to find a resolution anywhere. New install, on a fresh, clean install of WP (hosted by SiteGround). The install gives the same message as the OP: ![Installation Error Screen](i.stack.imgur.com/h3nzv.png) After installation, the Dashboard is effectively blank: ![Blank Dashboard](i.stack.imgur.com/dJ2dB.png) Please Help! – Patrick Kolasinski Aug 2 '17 at 16:59
1

I would recommend to get the CiviCRM package from sourceforge, the link is here:

Also please make sure to follow the installation instruction detailed here for installing CiviCRM in wordpress CMS.

I installed WP 4.7.4 and civi 4.7.18 on local and it got installed smoothly, yes it do gives notifications that you mentioned but that's expected:

  1. Cron Not Running

Configuring cron on your server is necessary for running scheduled jobs such as sending mail and scheduled reminders.

  1. Timestamp Mismatch

  2. Configure Default Mailbox

A default mailbox must be configured for email bounce processing.

  1. Complete Setup

Please enter your organization's name, primary address, and default FROM Email Address (for system-generated emails).

0

Hello Usman and Patrick - you managed to finish the install so your databases should be in place. Usman does your URL say just "/wp-admin/?page=CiviCRM&q=civicrm&reset=1" ? It should be preceded by your domain, masjidusman.ca, right? Make sure you have url-rewriting enabled - you should have a 'hidden' ascii file, .htaccess in your WP home folder and it should have something like RewriteEngine On RewriteBase /yourDomain/ ... in it. Make sure in your wp-content/plugins/civicrm/civicrm_settings.php file the baseURL says that, too. Your files folder perm doesn't need to be 777, 644 is ok. You both can try clearing cache files (/files/template_c) where all the compiled Smarty templates are. And check if your extension, templates_c etc. are under files/civicrm - they could be under plugins/uploads. Then if you finally can see the dashboard menu, check Directories and Resource Urls. And, finally, Patrick re the timestamp mismatch, check the timezone set in your php.ini file, you can google it. If your install is on linux which most likely it is, you should be able to configure/use just 'mail' or sendmail in Administration SMTP Mail settings.

  • Patrick re: timestamp, set that in Wordpress Dashboard Settings/General – Lesley Evensen Aug 2 '17 at 23:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.