I have been searching the database for this kind of error but was unbale to get it solved thus far.

I am trying to add a contribution page for users to sign up. I have defined two main user groups: members and administrators. Contact types as in the picture: Contact type definitions

And I want to add a profile "basic profile" to the sign-up including some custom set of fields, which I have defined as follows: Basic profile fields

If I want to add it to the contribution page, not even the drop down is visible, and it seems like a display error, but I have tried it on multiple browsers and the problem persists. I reckon it must be some sort of definition error which makes no profile pop up in my contribution page. But where is the faulty definition?

Thank you very much for your help, appreciate it! I am using wordpress 4.12.1

Best regards Joël

  • In your list of Profiles at Administer/Custom Data/Profiles and looking at this particular Profile 'Basic Profile', could you say what is shown in the Column named 'Used For'? It sounds like you may not have defined its use. Also, have you checked the box 'Is this CiviCRM Profile Active'? – peterb May 1 '17 at 15:54
  • @peterb It is defined to be used for User Registration, User Account, Search Views. As it is defined for registration I think it should be all set correctly?... – Jo Ou May 7 '17 at 13:47

It sounds like the problem is the one described here: Backbone isn't loading on Civi 4.6.11/WP 4.4.1

Please try changing your theme to the default theme, which doesn't conflict with Backbone. If you find that this solves the problem, you can follow the instructions on the other question on dequeuing Backbone from your WordPress theme.

  • CiviCRM need to use Backbone's noConflict mode – jackrabbithanna May 4 '17 at 18:10
  • 1
    This is a problem for the Drupal 8 version as well, Backbone ships with D8... – jackrabbithanna May 4 '17 at 18:11
  • @JonG Setting the theme back to twentyfifteen indeed solves the problem. I have created a child theme of fevr, but i was unable to locate the function which causes the backbone to load. The function you dequeued in your answer linked above doesn't exist in the fevr functions.php What do I have to look for in the code? – Jo Ou May 7 '17 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.