1

Using both WP & Drupal with different databases.

CiviCRM version : 4.6.28 Drupal version 7.54 Wordpress version :4.7.4

I am trying to use the search option given in CiviCRM. It fails in both WP & drupal with " Sorry but we are not able to provide this at the moment. DB Error: Unknown error"

why this issue is seen? What is the solution?

========================================================

#0 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Error.php(182): CRM_Core_Error::backtrace()
#1 [internal function](): CRM_Core_Error::handle(Object(DB_Error))
#2 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\PEAR.php(931): call_user_func((Array:2), Object(DB_Error))
#3 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB.php(976): PEAR_Error->PEAR_Error("DB Error: unknown error", -1, 16, (Array:2), "SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#4 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\PEAR.php(564): DB_Error->DB_Error(-1, 16, (Array:2), "SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#5 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\common.php(1905): PEAR->raiseError(NULL, -1, NULL, NULL, "SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...", "DB_Error", TRUE)
#6 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\mysql.php(895): DB_common->raiseError(-1, NULL, NULL, NULL, "1055 ** Expression #37 of SELECT list is not in GROUP BY clause and contains ...")
#7 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\mysql.php(328): DB_mysql->mysqlRaiseError()
#8 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\common.php(1216): DB_mysql->simpleQuery("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#9 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\DataObject.php(2442): DB_common->query("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#10 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\DB\DataObject.php(1634): DB_DataObject->_query("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#11 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\DAO.php(321): DB_DataObject->query("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#12 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\DAO.php(1181): CRM_Core_DAO->query("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...", TRUE)
#13 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Contact\BAO\Query.php(4685): CRM_Core_DAO::executeQuery("SELECT contact_a.id as contact_id, contact_a.contact_type  as `contact_type`,...")
#14 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Contact\Selector.php(550): CRM_Contact_BAO_Query->getCachedContacts("civicrm search b941cfc8ff1839fc77f5e89495a28257_3756", 0, 50, FALSE)
#15 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Selector\Controller.php(403): CRM_Contact_Selector->getRows(4, 0, 50, Object(CRM_Utils_Sort), 1, NULL)
#16 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Selector\Controller.php(340): CRM_Core_Selector_Controller->getRows(Object(CRM_Contact_Selector_Controller))
#17 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Contact\Form\Search.php(876): CRM_Core_Selector_Controller->run()
#18 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Contact\Form\Search\Advanced.php(330): CRM_Contact_Form_Search->postProcess()
#19 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Form.php(345): CRM_Contact_Form_Search_Advanced->postProcess()
#20 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\QuickForm\Action\Refresh.php(75): CRM_Core_Form->mainProcess()
#21 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Controller.php(203): CRM_Core_QuickForm_Action_Refresh->perform(Object(CRM_Contact_Form_Search_Advanced), "refresh")
#22 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contact_Form_Search_Advanced), "refresh")
#23 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Controller.php(353): HTML_QuickForm_Page->handle("refresh")
#24 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(312): CRM_Core_Controller->run((Array:4), (Array:0))
#25 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
#26 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(54): CRM_Core_Invoke::_invoke((Array:4))
#27 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm.php(1196): CRM_Core_Invoke::invoke((Array:4))
#28 [internal function](): CiviCRM_For_WordPress->invoke("")
#29 C:\wamp64\www\wordpress\wp-includes\class-wp-hook.php(298): call_user_func_array((Array:2), (Array:1))
#30 C:\wamp64\www\wordpress\wp-includes\class-wp-hook.php(323): WP_Hook->apply_filters("", (Array:1))
#31 C:\wamp64\www\wordpress\wp-includes\plugin.php(453): WP_Hook->do_action((Array:1))
#32 C:\wamp64\www\wordpress\wp-admin\admin.php(222): do_action("toplevel_page_CiviCRM")
#33 {main}
2

I think you might have mysql full group by mode on - 4.7 supports that (latest version is 4.7.19) but not 4.6. I think full group by is on by default or always on mysql 5.7

https://stackoverflow.com/questions/23921117/disable-only-full-group-by

  • cool !! thanks a lot. I was just frustrated with many reports giving the same error... was worried much on this. – Parthibaraj Rajasekar May 10 '17 at 11:50
0

If you turn on debugging you should get more information about the error & people will hopefully be able to interpret it for you - under Administer->System Settings->debugging and Error handling. Turn on debugging and backtrace.

  • Thanks, how do I share the error report... I am not seeing any option to attach files – Parthibaraj Rajasekar May 10 '17 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.