1

I recently upgraded from 4.7.18 to 4.7.19 (under Drupal 7.54) and now CiviSMTP (as well as my browser) gets Drupal's "Page not found" page when trying to get to my soap.php file.

Page not found The requested page "/sites/all/modules/civicrm/extern/soap.php" could not be found.

I've confirmed the file is in place, I'm using the default Drupal .htaccess file, file permissions seem to be at their defaults (AFAIK), and I'm out of ideas. My cron jobs are also not running, but I figure there's a common cause.

2
  • I assume CiviCRM is correctly enabled? seems very strange
    – Seamus Lee
    May 16 '17 at 10:34
  • As far as Drupal modules go? Yes.
    – Eric H
    May 16 '17 at 14:43
3

It turns out it was civicrm file permissions (in sites/all) conflicting with my server's PHP access settings.

My server dictates that if any part of a path is group writable, php file access will be denied. So I (well, my hired support person because I got desperate) went and set the directories involved to permission 755, and the file to permission 644 (civicrm/extern/soap.php).

My secondary problems with cron (civicrm/bin/cron.php) and not being able to browse for images in civimail (civicrm/packages/kcfinder/*) were fixed by following the same logic.

I'm still not sure why this was triggered by an upgrade from 4.7.18 to 4.7.19. I must have made a misstep during file copying.

2
  • Just to tag on here, this happened to us as well, but we noticed it because we couldn't upload images in CiviMail, and click tracking was broken in CiviMail as well. Changing permissions on the files solved it. May 26 '17 at 18:32
  • We also had cron job failing to run after upgrades (to 7.4.24 on Wordpress). Copying the url from the wget command and plugging in to browser bought up the message "Incorrect file/directory permissions: Above 755. In order files to be processed by the webserver, their permissions have to be equal or below 755." Changing permissions on cron.php from 664 to 664 seemed to sort it.
    – Eric Booth
    Sep 26 '17 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.