1

daniel-strum 8:08 PM

Maybe someone can point me in a direction to look... I posted this last night on MatterMost and got a few replies but I'm still stuck.

I have an Drupal7 Civi 4.7.17 instance that will not send email from CiviMail. I started with the Sparkpost (com.cividesk.email.sparkpost) extension and that worked about 3 months ago when I set it up. The client then just disappeared till now. Sending test emails from the setup screen for Sparkpost works as does sending emails from a contact's record and even donation receipts work. I have also tried switching to a simple SMTP setup and even sendmail. All work in all cases except when using the CiviMail (bulk email) interface. Even "Send a Test" to an a contact or a group in CiviMail just does not work. It says it was sent and even the mail report says it was sent. No errors in Drupal's watchdog. If I uncomment the "send the email to a log" line in civicrm.settings.php, I see all emails in the log except any that are created from the CiviMail interface. It does not seem to be generating any errors that I can find in ConfigAndLog > xxx.log. Any ideas?

Thanks

  • Is there anything in sparkpost_log? If you log on to Sparkpost, does it shows the mails reaching Sparkpost? – Aidan May 15 '17 at 14:23
  • No, there is nothing in the sparkpost log for anything sent through CiviMail. I can find other item that are sent by CiviCRM but none of the ones that are sent by CiviMail. – Daniel Strum May 15 '17 at 18:32
  • How about the Sparkpost website? Anything showing on there? – Aidan May 16 '17 at 7:05
  • Is the system Job for Sending Scheduled emails on? However, this should not impact the sending of the test email from CiviMail. – Ron Gridley May 20 '17 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.