2

after a successful installation of CiviCRM 4.7.19 on WordPress 4.7.4 – the installer said everything was fine –, the menu and dashboard of CiviCRM does not show.

I know, this issue has been addressed elsewhere, but the solutions proposed there didn't work for me.

For instance, in the following case: Civi dashboard and menus won't display after install the solution seemed to be to replace the CiviCRM Resource URL which was set to default. However, the solution does not say, how to find and access this Resource URLs settings page where this default would have to be changed.

In another solution Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus it was suggested to install a certain plugin https://wordpress.org/plugins/civicrm-admin-utilities/ , which unfortunately also did not help me.

I've also looked into similar cases on Drupal, like this one: Civicrm menu is hidden There someone suggested to rebuild the menu via adding /civicrm/menu/rebuild to my page, but it only gave me an error saying I'm not permitted to access that page.

I'd be glad to hear some of your ideas on this issue.

Thanks and best regards! Jannis

EDIT: Posted the solution below.

  • 1
    Jannis, what does your civicrm.settings.php file show as the value for your BASEURL, is it correct, is your site using SSL (https)? In 4.7 the civicrm settings file ends up in 'wp-content/uploads/civicrm' folder. – Lesley Evensen May 16 '17 at 18:26
  • 2
    In the case where you cannot use the dashboard (and therefore Admin functions) to set 'resource URLs' you can go into the database to see what they're set to (and change them if needed): if you're using MySQL you can look at the civicrm_settings table and check 'value' where 'name' is like 'imageUploadURL' and 'userFrameworkResourceURL' (the latter should be your 'civicrm' root, like wp-content/plugins/civicrm.. – Lesley Evensen May 16 '17 at 18:47
  • double check your permissions? – petednz - fuzion May 16 '17 at 23:09
  • Is there anything useful in the civicrm or webserver log files? – Aidan May 17 '17 at 8:03
  • Dear all, thank a lot for your comments! @LesleyEvensen: I checked the BASEURL and it just said crm.netzwerk-n.org, which is the right domain. But as petednz suggested that it might be a problem of permissions, I added "/wp-admin/" to the BASEURL, which however did not change anything. – Jannis Eicker May 17 '17 at 9:39
2

Thanks for all your good ideas. Finally I've solved it by going through the first case I've listed above: civicrm.stackexchange.com/questions/17483/… Though I could neither access the menu nor find the resource URL in my database, I found a link to the administer page in the case, which is wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin&reset=1 There I could change the default to the actual CiviCRM Resource URL.

  • 1
    Thank you for updating your question! I see you've marked the question as "SOLVED" in the title. Could you please check the box next to this answer to indicate that this is the correct answer? Thanks! – Jon G - Megaphone Tech May 18 '17 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.