0

CiviCRM 4.7.19 / Drupal 7.54

I am stuggeling with the setup of the default mail account in CiviCRM (... /civicrm/admin/mailSettings?reset=1)

I have setup a IMAP mail account for processing bounced email. Receiving email in this mail account works using my mail client using information below.

  • Mail account info:

    Email address: bounces@mydomain.org

    Username: bounces@mydomain.org (ISP requires that the full email address be used for the username)

    Password: mypass

    Server: mail.mydomain.org

    Protocol: IMAP

    SSL: is activated

.

  • CiviCRM (CiviMAIL) settings:

    Name: Bounce processing

    Server: mail.mydomain.org

    Username: bounces <<<<--- should be full email addres: bounces@mydomain.org

    Password: mypass

    Local part:

    Email domain: mydomain.org

    Return address:

    Protocol: IMAP

    Source:

    Use SSL: checked

    Used for: processing bounces

.

Results Cron Job -

Entiteit: job Actie: fetch_bounces Summary Finished execution of Fetch Bounces with result: Mislukt, Error message: A fatal error was triggered: Kan geen verbinding maken met Mailstore voor bounces@mail.mydomain.org Foutmelding:

An error occured while sending or re (...) Details

Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;}

Full message: Finished execution of Fetch Bounces with result: Mislukt, Error message: A fatal error was triggered: Kan geen verbinding maken met Mailstore voor bounces@mail.mydomain.org Foutmelding:

An error occured while sending or receiving mail. Failed to connect to the server: mail.mbrainingcentrum.com:993.

.

When I use the full email adress as username I get errors referring to: bounces@mydomain.org@mail.mydomain.org

Looks to me that CiviCRM(CiviMAIL) has a bug regarding concatenatig proper parts.

Any solution?

Many thanks in advance !

Best regards, Ton

1

CiviMail doesn't concatenate the username to the servername, it just takes whatever you provide and tries to connect using those credentials.

But my guess is that the issue is unrelated to the username, since your error message is:

Failed to connect to the server: mail.mbrainingcentrum.com:993.

I'd guess that you've more likely got a firewall issue, or an SSL issue on your server.

You can test by manually trying to connect to your mail server, using e.g. the instructions here: https://technet.microsoft.com/en-us/library/aa995718(v=exchg.65).aspx

[As per comment below - another thing to check is that the server is connecting to the correct machine, e.g. if it has a local dns setting that is wrong.]

  • Dear Alan, Thank you for the pointer. DNS settings had changed, Solved ! – TonV May 19 '17 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.