I'm using the latest version of CiviCRM for Joomla and trying to create a new event or copy an existing one and I'm getting this error:

An error has occurred. 0 @import url(/administrator/components/com_civicrm/civicrm/css/civicrm.css); @import url(/administrator/components/com_civicrm/civicrm/bower_components/font-awesome/css/font-awesome.min.css); Sorry but we are not able to provide this at the moment. You do not have permission to access this page.

Return to home page.

function toggle( element ) { var parent = element.parentNode; var className = parent.className; if ( className == 'crm-accordion-wrapper collapsed crm-fatal-error-details-block') { parent.className = 'crm-accordion-wrapper crm-fatal-error-details-block'; } else { parent.className = 'crm-accordion-wrapper collapsed crm-fatal-error-details-block'; } }

When I check the CiviCRM log, I see:

May 22 20:22:24  [info] $Fatal Error Details = Array
    [message] => You do not have permission to access this page.
    [code] => 

May 22 20:22:24  [info] $backTrace = #0 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(378): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Event/Form/ManageEvent.php(128): CRM_Core_Error::fatal("You do not have permission to access this page.")
#2 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Event/Form/ManageEvent/EventInfo.php(47): CRM_Event_Form_ManageEvent->preProcess()
#3 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Form.php(543): CRM_Event_Form_ManageEvent_EventInfo->preProcess()
#4 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php(92): CRM_Core_Form->buildForm()
#5 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Event_Form_ManageEvent_EventInfo), "display")
#6 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Event_Form_ManageEvent_EventInfo), "display")
#7 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Controller.php(351): HTML_QuickForm_Page->handle("display")
#8 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Utils/Wrapper.php(113): CRM_Core_Controller->run()
#9 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(283): CRM_Utils_Wrapper->run("CRM_Event_Form_ManageEvent_EventInfo", "Event Info and Settings", (Array:0))
#10 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(84): CRM_Core_Invoke::runItem((Array:14))
#11 /home/mysite/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:4))
#12 /home/mysite/public_html/administrator/components/com_civicrm/civicrm.php(121): CRM_Core_Invoke::invoke((Array:4))
#13 /home/mysite/public_html/administrator/components/com_civicrm/civicrm.php(40): civicrm_invoke()
#14 /home/mysite/public_html/libraries/cms/component/helper.php(394): require_once("/home/mysite/public_html/administrator/components/com_civicrm/civicrm.php")
#15 /home/mysite/public_html/libraries/cms/component/helper.php(369): JComponentHelper::executeComponent("/home/mysite/public_html/administrator/components/com_civicrm/civicrm.php")
#16 /home/mysite/public_html/libraries/cms/application/administrator.php(98): JComponentHelper::renderComponent("com_civicrm")
#17 /home/mysite/public_html/libraries/cms/application/administrator.php(156): JApplicationAdministrator->dispatch()
#18 /home/mysite/public_html/libraries/cms/application/cms.php(265): JApplicationAdministrator->doExecute()
#19 /home/mysite/public_html/administrator/index.php(51): JApplicationCms->execute()
#20 {main}

I checked the folder permissions and everything is 755. This may have started with Joomla 3.7 or 3.7.1, but I can't be sure. I also tried switching between PHP 5.6 and 7.

enter image description here

I did some further investigating and the event is getting created/copied in the civicrm_event table, but isn't showing up in the Events section.

  • I tried manually changing the component permissions in the assets table and this had no effect. It's looking more and more like a bug in CiviCRM and the way it handles permissions with Joomla 3.7+.
    – severdia
    May 23, 2017 at 13:40
  • When I revert the civicrm_events table back to its default, adding events works. I've noticed that the CiviCRM Database Upgrade Utility doesn't work very well. When comparing my tables with those of a default installation, columns are out of order, column comments are missing and there are various small issues with column settings (like tinyint 1 instead of 4). I've manually updated the bigger issues, but the upgrade utility should really be fixed.
    – severdia
    May 23, 2017 at 17:53

2 Answers 2


This issue is not permissions related. It's a problem with CiviEvent not showing or allowing you to create more than 26 events. I can reproduce this on a fresh install of the latest version of Joomla and CiviCRM.

Can't create more than 26 events in CiviEvents (or view on dashboard)


I believe that error is more suggesting an issue with the permissions associated with the role. it looks like you need to grant edit permissions for CiviEvents as per https://github.com/civicrm/civicrm-core/blob/master/CRM/Event/Form/ManageEvent.php#L128.

Those sorts of errors are typical where the role that you have has insufficient permissions defined in your content management system (CMS)


  • I'm a Super User and all the permissions are green/allowed in the Global Configuration for CiviCRM. I used to be able to add events and the role settings have not changed since then.
    – severdia
    May 23, 2017 at 2:10
  • I added an edit ACL for admins in the CiviCRM config and it had no effect.
    – severdia
    May 23, 2017 at 2:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.