2

when we upload a file to the Media Library at https://OurSite.org/wp-admin/upload.php the file doesn't show up onscreen immediately. It looks like nothing has happened. But when we refresh the browser, the file appears.

We thought perhaps this was a SiteGround caching issue, so added wp-admin/ to the exclusion list and used the Supercacher testing tool to confirm that https://OurSite.org/wp-admin/upload.php was now excluded.

We also purged the SiteGround cache, but still the Media Library does not dynamically refresh when uploading a file. Wordpress version is 4.7.2 and CiviCRM version is 4.7.13

We have the same Wordpress version installed on a different host and it is working properly. We confirmed that it is caused by CiviCRM when we disabled the CiviCRM wordpress plugin. We looked for possible collisions of libraries, but it is not evident why CiviCRM is affecting any of the output on that page. We're looking for insights from someone with additional Wordpress expertise.

  • Have you switched to a default theme to see if you theme is responsible? – Christian Wach May 25 '17 at 9:49
1

Not quite a complete answer yet, but I had the same problem with SiteGround and it is to do with file permissions. See Adding images in CKEditor for what I changed.

Also see my recent question file permissions with hosted wordpress about the wider issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.