1

I'm experiencing a curious issue that I've been unable to fully resolve. After Microsoft modified their SPF detection sometime late last year, I discovered that the SPF record for my organization had never been correctly configured on our website and all outgoing messages where failing Fraud Detection for Outlook recipients.

I did some research and configured our SPF Record and this seemed to resolve the issue for the primary general email address for our organization's domain. However, time passed and one of our other users attempted to send an email using their email address (on the same domain) as the From address, and those messages still triggered the Fraud Detection. I've tested with other email addresses on the domain and replicated this issue, while the primary address continues to send without issue.

Any thoughts on how to resolve this situation would be greatly appreciated.

2

Email delivery can be a tricky business and there can be many reasons why this is happening.

To diagnose, I use https://www.mail-tester.com/

It will give you a score out of 10 and let you know where you can improve, giving you details of SPF and DKIM records which may be causing issues with delivery.

You can just put the testing email provided by Mail Tester in the same place you put any email to send a test message in CiviMail. I'd recommend changing the from address on different tests and see how the score changes. Based on what you described, I would expect some feedback about your mail records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.