2

Both English and French are enabled under Languages Options.

However, I have yet to see the green buttons several posts have mentioned.

For the email greeting, I had attempted to use the solution proposed by a German user. In French one uses Cher and Chère, but this does not work.

{capture assign=l}{contact.preferred_language}
{/capture}{capture assign=g}{contact.gender}{/capture}
{if $l="fr_CA"}
   {if $g="Female"}Chère{else}Cher{/if} 
{else}Dear{/if}
{contact.first_name} {contact.last_name}

All I get is Network Error.

3

Languages options allow you to limit the preferred language for your contacts. It's not related to multilingual setting.

To enable multilingual, you need to go to :

  • menu Administer -> Localization -> Language, Currency, Locations
  • go to the latest section "Multiple Languages Support", check the box "Enable Multiple Languages" (this will change the structure of your database so do a backup first) and Save
  • go to this page again, and you should see a "Add Language" with a dropdown list : choose one and Save

Now you should be in multilingual mode and should see the green/grey buttons where applicable.

Concerning "email greeting", i think you need to enable smarty in this context. Try to add in your civicrm_settings.php (see also https://wiki.civicrm.org/confluence/display/CRMDOC/Smarty+in+mail+templates) :

define( 'CIVICRM_MAIL_SMARTY', 1 );
  • I tried the Enable Multiple Language Support. Thank goodness it was my sandbox site. It started creating new tables and blew up in the middle. I will revisit this after a few more versions go by. – Codedogs Sep 9 '17 at 0:44
  • Just to let you know, we use the multilingual option with dozens of CiviCRM installations and i haven't seen any crash while changing the unilingual / multilingual option for years. The problem might be with your hosting provider (timeout ?). In any case, if you don't give a more detailed report of what went wrong, there is very little chances that we could help you / resolve the problem. You might want to go to chat.civicrm.org -> translation channel to have specific support about it. – samuelsov Sep 12 '17 at 15:39
  • Pretty certain it was a timeout. Any suggestions to get around this? – Codedogs Sep 13 '17 at 19:32
  • Depending on your hosting, you might be able to raise the limit by adding in your civicrm.settings.php : ini_set('max_execution_time', 120); // 120 is the number of seconds your php script could take. If you got a blank screen and want to see the exact error, you can add to your civicrm.settings.php : ini_set('display_errors',1); ini_set('display_startup_errors',1); – samuelsov Sep 19 '17 at 13:35
  • It could also be a hosting limitation on triggers or views. Difficult to speculate without the exact error message (which should be in your ConfigAndLog directory). – bgm Nov 29 '17 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.