2

I'm getting the following error when running the "Fetch Bounces" scheduled job:

Details

Parameters parsed (and passed to API method): 
a:1:{s:7:"version";i:3;}

Full message: 
Finished execution of Fetch Bounces with result: Failure, Error message: A fatal error was triggered: Could not connect to MailStore for ebounce@domain.com@imap.gmail.com
Error message: 

An error occured while sending or receiving mail. Failed to connect to the server: imap.gmail.com:993.

The mailbox is a G Suite account, IMAP is configured, and I can connect to the mailbox via IMAP from an Outlook email client. The error appears in the job log immediately after running the job (there's no 30 second or longer delay that I would expect if it were timing out trying to connect to the mailbox).

Where can I look (or how can I get) some more detailed information on why this job might be failing so quickly?

As per the recommendation, we're running Wordpress 4.8 and CiviCRM 4.7.19

Thanks!

  • assuming you anonymised this "Could not connect to MailStore for ebounce@domain.com@imap.gmail.com" – petednz - fuzion Jun 14 '17 at 5:29
  • Welcome to StackExchange! It would be helpful if you could edit the question to show the version of CiviCRM and WordPress that you are using as this may affect the answers. – William Mortada Jun 14 '17 at 17:10
  • Version numbers added and yes, @domain I just a place-holder. Thanks for the suggestions; first time poster and new to the software. – mzier Jun 14 '17 at 19:54
2

The issue is likely at the server networking level. If you have access to that server (via SSH or similar), I would try installing the swaks utility to troubleshoot.

swaks might even be premature though. I would start by ensuring that your server's firewall isn't blocking outgoing access on port 993 and that imap.gmail.com is resolving in DNS.

  • And the server it was. We were trying to get everything set up on GoDaddy hosting which inhibited ports. After switching to Linode, without any other changes, all our issues resolved. Hopefully this helps anyone in a similar situation. As guyiac mentions below, Google apps accounts need to allow less secure apps as well. – mzier Jul 31 '17 at 14:44
2

Gmail likes you to go in and turn on the "Allow less secure apps" setting, if you haven't done that yet. They aren't so clear about what exactly makes the app less secure according to Google, but they are an attractive option because of the price and because gmail supports address+ processing. If you choose to do it, sign into the Google account you are trying to use, choose My Account, select Sign in and Security, scroll to the bottom, and turn on "Allow less secure apps."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.