0

I have Civicrm 4.7.20 installed on Wordpress 4.8.

When I create a new event or contribution the link that Civicrm creates does not work. What Civicrm creates as a link: http://[mysite]/?page=CiviCRM&q=civicrm/event/register&reset=1&id=7 This link loads my Civicrm base page, in this case my home page. If I change the base page to a different page then that page is loaded.

This link works: http://[mysite]/?page=CiviCRM&q=civicrm/event/info1&reset=1&id=7&page_id=1811

Note the &page_id=1811 parameter

As long as I specify the parameter &page_id=[any valid page] the link works, if I don't specify then the link loads the base page.

I tried disabling all other plugins and nothing changed so I think it has to be a Wordpress or Civicrm setting problem.

2
  • Is WordPress installed in a sub-directory or the root directory of the site?
    – KilakwaBT
    Jun 17, 2017 at 11:08
  • WordPress is installed on the root directory
    – corsair
    Jun 19, 2017 at 13:17

1 Answer 1

0

do you have Permalinks 'plain' enabled (in WP Dashboard/Settings)? Or do you have custom? I don't know if that makes a difference but it relates to how URLs are constructed. I switched between plain and custom Permalinks. And in civicrm Wordpress Integration how did you configure your 'base' page? I used the postname of my WP base page (ie, just 'civicrm') and it seems to work, civicrm event pages show. Does your .htaccess file have URL rewriting enabled (begins like "# BEGIN WordPress RewriteEngine On.."
In the URL for, say, an event I get "page=CiviCRM&q=civicrm%2Fevent%2Finfo&id=1870&reset=1" where &id=1870 is the registration form for an event I created. I am using 4.7.20 and WP 4.8 also

2
  • And check what is the permalink for your civicrm base page (edit the page in WP) Jun 17, 2017 at 2:25
  • Adding "RewriteEngine On" block from codex.wordpress.org/htaccess to .htaccess fixed the problem, now the civicrm generated link works. http://<mysite>/civicrm/?page=CiviCRM&q=civicrm/event/info&reset=1&id=7
    – corsair
    Jun 19, 2017 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.