I'm using CiviCRM 4.7.20, but the problem showed up at some point while I was using 4.7.11. I'm using the current version of WordPress. I'm the administrator and used this userID/password to upgrade to 4.7.20, hoping this problem would go away. WordPress Users shows that I'm the administrator. At some point, the Report links on the CiviMail Report screen, started giving me: "Sorry but we are not able to provide this at the moment. You do not have permission to access this page." I can still access the Advanced Search links on the same screen. What's going on??

I'm using the WP Members Plugin, but disabling it doesn't help. I've gone into WP Roles and made sure the Administrator is granted every permission and denied nothing. What's going on??

Here's the backTrace I get from clicking on menu item: Mailing Reports

#0 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(374): CRM_Core_Error::backtrace()
#1 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/WordPress.php(354): CRM_Core_Error::fatal("You do not have permission to access this page.")
#2 [internal function](): CRM_Utils_System_WordPress->permissionDenied()
#3 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Utils/System.php(74): call_user_func_array((Array:2), (Array:0))
#4 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(230): CRM_Utils_System::__callStatic("permissionDenied", (Array:0))
#5 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(230): CRM_Utils_System::permissionDenied()
#6 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(84): CRM_Core_Invoke::runItem((Array:14))
#7 /home/mysite/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#8 /home/mysite/wp-content/plugins/civicrm/civicrm.php(1227): CRM_Core_Invoke::invoke((Array:3))
#9 [internal function](): CiviCRM_For_WordPress->invoke("")
#10 /home/mysite/wp-includes/class-wp-hook.php(298): call_user_func_array((Array:2), (Array:1))
#11 /home/mysite/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters("", (Array:1))
#12 /home/mysite/wp-includes/plugin.php(453): WP_Hook->do_action((Array:1))
#13 /home/mysite/wp-admin/admin.php(222): do_action("toplevel_page_CiviCRM")
#14 {main}
  • C'mon folks, somebody please give me a clue! I have my own 4.7.20 sandbox WordPress website. It has the same permissions problem. I deleted the WP Members Plugin. I poked around in the ACL Access Control screens, but couldn't find anything wrong. I went to wpmaster.demo.civicrm.org sandbox and clicked on Mail Reports and it takes me to that screen. I tried the same thing with my website and I get the same permissions error described above. What's going on?? An Administrator should be able to get to the Mail Reports screen, right? Please help!!
    – jimcrist
    Jun 22, 2017 at 2:44

2 Answers 2


I fixed it. At some point I disabled the CiviReport component of the system. I didn't know I needed CiviReport to look at that part of CiviMail. A better error message would be nice!

  • Thanks for sharing this; saved me a lot of time and frustration with the same problem! I agree about a better error message.
    – Norris
    Jul 14, 2017 at 2:26

I don't use wordpress often but have you checked the wordpress/civicrm permissions?

on an outdated instance I have access to I found that at the following url /wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/access/wp-permissions&reset=1

do you have "CiviReport: access CiviReport" permissions on the roll you are using?

  • Sadly, that's not it. At the top of the screen you pointed me to it says "NOTE: Super Admin and Administrator roles will have all permissions in CiviCRM." I have tried creating a new user, give them administrative rights plus a keymaster role which has every possible permission and I still can't get into Mail Reports. WAIT. I fixed it. At some point I disabled the CiviReport component of the system. I didn't know I needed CiviReport to look at that part of CiviMail. A better error message would be nice!
    – jimcrist
    Jun 24, 2017 at 15:45
  • I'm glad you figured it out. it does seem pretty intuitive to me that if you expect the system to mail reports that the reporting system must be enabled, but I agree that better error messages would be great
    – ericG
    Jun 25, 2017 at 16:45
  • Just wanted to thank you @jimcrist for posting your own answer. It is 2022 now and it fixed my issues! May 4, 2022 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.