2

I'm hoping someone can help me with this issue I'm having. All contributions on the Dashboard and Find Contributions screen have the exact same date and time for the Received date and Thank-you Sent date. Attached is a screen shot. The top has a Thank-you Sent date of June 18th, 2017 12:00 AM and the second does not have a Thank-you Send date set. I am currently running the site on Amazon AWS Linux with Drupal 7.55 and CiviCRM version 4.7.20. I am getting the "missing indices on some tables" performance warning and try to Update them but it errors out in the logs.

enter image description here

enter image description here

How do you fix this? I looked at the CiviCRM demo and the same issue is happening. Is this a bug? or is it just me? This is a screenshot of the html on the Contribution Dashboard page, the second receive is suppose to be Thank you date.

enter image description here

  • Welcome to StackExchange! This looks like a good question. You could improve it and help people to provide better answers by editing your question to provide a bit more detail. In particular the version of CiviCRM and the CMS you are using (Drupal, WordPress or Joomla). – William Mortada Jun 19 '17 at 21:45
  • Thank you! And thanks for the advice. I have updated this. – Scott Pulver Jun 20 '17 at 13:52
3

There is an open issue related to your question https://issues.civicrm.org/jira/browse/CRM-20894. It also happens to me with a recent upgraded CiviCRM from 4.8 to 4.7.22 and it can also be replicated in dmaster.

[EDIT]

Seems it's already solved here https://issues.civicrm.org/jira/browse/CRM-20773

2

Scott, it sounds like 2 issues; the receipt date(s), and 'missing indices'. Did you/all send a 'thank you' email? The default setting is to reset the receipt date (checkbox). Re: the missing indices - for which tables? You can find how to see which ones are 'missing' by looking in another stack exchange item (How to find and/or fix missing indices?). The one for civicrm_case_contact is a bug - look in your database first, that table probably is set up correctly. Alternatively you can choose to 'hide'

  • Thanks for helping me out. I did know about the missing indices and the bug where it errors out. Was not sure if these two problems were connected though. I am more worried about getting the receipt date and thank you dates showing properly. I updated the original post with some more info and screenshots. – Scott Pulver Jun 20 '17 at 15:13
  • Shows June 18th, 2017 11:00AM for both received and Thank you date on Contributions Dashboard – Scott Pulver Jun 20 '17 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.