2

I have a list of contacts (names and email addresses). I know that all of these contacts are in the Civi database, but I want to add a tag or a group to all of them, and i have the list in a CSV file. What I should be able to do is simply import the contacts, setting 'Update' or perhaps 'Fill' as my duplicate matching option, and set the tag and/or group to be set in the import settings. Just tried it - several times, using various different options, and it failed every time, reporting that 0 records had been tagged (or added to the group). This is with Civi 4.7.19.

Is there a specific set of options that I need to know about to get this to work? This post (How to tag a contact when importing possible duplicates) suggests that this should just work. I followed that example and it failed.

  • Hi Graham. Sounds odd. The only situation I know of where Tagging as the last step of an import is when a timeout issue happens (which is why i strongly advocate adding a custom field purely for the purposes of tracking the import process - and if you do that then you could do a search and Tag if the import tagging fails. But that is an extra step and should not be required. Did you confirm on Demo? – petednz - fuzion Jun 19 '17 at 20:36
  • With the demo site I was successfully able to import a set of new contacts and add a new tag on import. If I then removed the tag from those contacts and ran a second import form the same file, using the 'update' option, and requesting that the tag be added on import, no tag was added. – Graham Jun 20 '17 at 7:52
  • Looks like this is linked to issues.civicrm.org/jira/browse/CRM-20742 – Graham Jun 20 '17 at 8:11
  • And issues.civicrm.org/jira/browse/CRM-20739 – Graham Jun 20 '17 at 8:12
  • Couldn't you just use the api explorer? – nielo Jun 20 '17 at 20:54
1

To bypass this problem, I use Yes/No custom field to import the data "Belonging to A group". Then I use an advanced search to select those contacts and add them to the A group.

1

I also stumbled across this bug - when a user already exists, trying to import and assign tags using the email/dedupe failed.

Mentioned in one of the jira issues https://issues.civicrm.org/jira/browse/CRM-20739 is "When performing a contact import using the "fill" option and using a dedupe rule to match (i.e. not including the contact ID in the import structure), the contacts will not be added to a group."

I found that if I import based on the contact ID, the additional tag was added - may not be a great solution for everyone but it's a workaround I can live with for now.

0

I think I face the same issue.

I tried many thing (import more than email for this 2nd import, change group visibility, use a new group, etc.) but it is still the same.

The import report always mentions "One contact added to this existing group." But when I go to group panel, the group has no new contact.

  • 1
    Which version of CiviCRM are you working with Charles? issues.civicrm.org/jira/browse/CRM-20739 was fixed in version 4.7.23 so if you are on an earlier version it might be worth updating and see if it resolves your problem. – Graham Oct 3 '17 at 10:34
  • I confirm ! Problem solved by updating to CiviCRM 4.7.29 – Charles Letaillieur Mar 28 '18 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.