1

We use CPanel to run crons on our sites. The cron had been working fine and then stopped some months back. I've tried every example I can find, but it still is not running properly.

I've attached a screenshot of what the cron looks like in CPanel as well as the cron in text (redacted to remove personal info). The username, password, and key are all letters/numbers - no special characters.

wget -O - -q -t 1 'https://www.DOMAIN.org/sites/all/modules/civicrm/bin/cron.php?name=USERNAME&pass=PASSWORD&key=KEY'

Cron screenshot

  • Have you tried another cron job, something simple like a script that adds 2+2 and get the result? Do you have shell access there and can you shell in and try your wget command from the commandline? And finally, when is the last time you got an email (the cron job should send you an email if it's running)? – Lesley Evensen Jun 21 '17 at 23:27
  • I wanted to add that if your cron job is being run, you (the admin) should be getting an email every time the cron runs. If there's an error you'd still get the email; if no email, seems cron isn't running. – Lesley Evensen Jun 22 '17 at 21:15
  • No emails. Just noticed another account is having the same problem. So I guess I will put this on hold for the moment, as we're in the middle of migrating to a newer server. Then if it doesn't run there, I'll ask the webhost for help since no one has pointed to any issues with the format of the cron. – Jenni Simonis Jun 23 '17 at 3:30
1

Since you're using a wget-based cron, there should be a corresponding entry in the web server log for each cron run. Look to see the Apache value - does it return 404 or 500 or maybe something else? 404 would indicate a wrong URL; 403 would indicate it's blocked, perhaps because of the user agent (iThemes Security for WordPress does this in its default configuration). A 200 or 500 would mean to check the CiviCRM log in ConfigAndLog.

0

I had an issue like this once. The cron was being run by logging in with a username and password and the password for that user had changed so the cron was not able to access properly.

  • Nope, the password is correct. I'm the only one who has access to the users. I even went and copied the password from the cron and made sure it was the same for the user. It was. Username is correct as well. Has full CiviCRM priviledges. – Jenni Simonis Jun 23 '17 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.