2

I have activated "Sales tax" as per [the documentation], including adding Financial Type and Accounts ("Arrangemangsavgift inkl. moms"):

enter image description here

I've also set my event to use the Finacial Type to the one in the picture. But there is no sign of any "moms" (=VAT). Particularly I'd like to have my event registration page clearly state the VAT.

Update: I have a Price Set which uses the Financial Type: enter image description here

And I've explicitly set the Financial Type of the event to use it too: enter image description here

I don't see any summary/breakdown with VAT on the registration page, and any contribution created by a registration does not have such a breakdown either.

What is a good checklist to get VAT for event registrations to work? Or maybe, why does not ours work ;-)

3

To enable Sales tax for an Event.

  1. Enable Enable Tax and Invoicing setting in Administer >> CiviContribute >> CiviContribute Component Settings
  2. Create a Financial Account of type Liability, Is Tax Enabled and Tax Rate > 0.
  3. Link Financial Account with Financial Type using 'Sales tax Account is'.
  4. Use financial type configured for tax at #3 for event, price set, and price fields.
2

Look for the priceset that is being included in this event. This priceset should have the tax enabled financial type selected in settings.

If you haven't created a priceset - create one from Administer -> CiviEvent -> New Priceset and set the financial type to the one that has a sales tax. Use this priceset on the Event Page.

  • I already had that. Updated the question with more pictures to show that. – thoni56 Jun 27 '17 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.