1

I have set up a webform to receive gift memberships so that one individual can purchase a membership for another. Although the instructions seem relatively straightforward (see here and here), the payment page/form does not display an area to actually submit credit card information.

Any insight would be appreciated.

Some details: The problem is not specific to gift memberships, but webforms. The webforms on our site integrate fine with civiCRM, EXCEPT for accepting payment. So for example, I use webforms for non-paying memberships and everything works fine. I have tried setting up just a webform that links to a contribution page and it does not work.

So, per the civiCRM webform documentation, "Using Webforms, you can accept online payments for contributions, events and memberships or any combination of these on a single form."

THe documentation then states that "When creating a contribution, event or membership webform that includes payments, first set up a dedicated contribution page for the sole purpose of embedding it on one or more webforms. Most of the contribution page settings will be ignored by the webform. Only the following need to be configured: Title: This will be displayed on the webform Financial type Currency Payment processor Email receipt - if enabled, these will be sent from the webform just as they would be from the real contribution page"

On the backend, all of this makes sense. I have set up a dedicated contribution page and configured each of the items listed above (title, etc). I have tested the dedicated contribution page, and it works fine. The problem seems to be in how the page connects to the webform. But I do not see anything wrong on the backend, nor have I found someone discussing a similar problem.

I've included three images: (1)Purchase gift membership contact info screen: this is the initial webform that takes an individual's information. Everything appears ok here.enter image description here

(2)Purchase gift membership payment screen: note that there is not a way to fill in a credit card, nor is membership amount listed.enter image description here

(3)Finally, the edit screen for the webform. This is where the webform is instructed to connect to a contribution page.

1:enter image description here https://i.stack.imgur.com/lKSWu.png

  • hi Laurynn - it would probably help others if you flesh out your info a bit. eg what payment processor? does webform work for non-gift memberships? etc – petednz - fuzion Jun 28 '17 at 3:44
  • hey petednz, I've added more explanation and some images. The payment processor is CDG commerce. I saw in the documentation that the payment processor could be a problem, and maybe that's what is going on. But, and I could be wrong, if the payment processor were the issue, I would expect that the information would display (see image), but not simply not process. As you will see from the image, the payment page is essentially blank. – LaurynnLowe Jun 28 '17 at 15:37
  • also, sorry, yes, I just did a test and webforms integrate with civiCRM. As long as there is no payment involved, the webform will accept the contact information and add the contact to the civiCRM database. – LaurynnLowe Jun 28 '17 at 15:47
  • what about non-gift memberships? i am trying to help you strip down the problem to ... 'this is a problem with any payment' or 'this is a problem with payment + membership' or 'this is a problem with payment + GIFT membership' or 'this is a problem with just this payment processor'. etc. hth – petednz - fuzion Jun 29 '17 at 21:22
  • non-gift membership is fine. but the problem is resolved; the module needed to be updated – LaurynnLowe Jun 30 '17 at 15:01
1

Resolved: module needed to be updated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.