0

I have moved the installed civicrm with Drupal from windows PC to Linux PC and changed the civicrm settings file. Everything working fine but only the javascript files are not loading.

The resource from “http://localhost/drupal/sites/all/modules/civicrm/modules/templates/CRM/Member/Form/MembershipStandalone.js?os8oog” was blocked due to MIME type mismatch (X-Content-Type-Options: nosniff).

I went to the folder paths files are exist. How to overcome this issue

2

The X-Content-Type-Options: nosniff header is a security measure that prevents the browser from attempting to detect the MIME type of a download automatically, as this behavior can be exploited for certain kinds of attacks. The browser will block requests for stylesheets and scripts which are not delivered with a CSS or Javascript MIME type, respectively.

In practice, this means the web server is unable to load the resource for any of several reasons:

  • The resource is missing
  • The file permissions on the resource prevent it from being loaded by the web server
  • The web server is not configured to deliver .js files using a Javascript MIME type

Please confirm that the file exists, that you have followed all the instructions for moving an existing installation, and that your server is configured correctly, including file permissions and Javascript MIME types. In particular, since this file is loaded in a custom template, you should confirm that the path has not changed.

  • You are correct the resource is missing; I opened the URL in chromium browser it shows 404 error; I had a typo error in settings file. It caused to produce the URL like "modules/civicrm/modules" as in my question; but the actual path is 'modules/civicrm/" – ManiMuthuPandi Jun 29 '17 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.