1

I've a got a local sandbox running CiviCRM 4.7.18 on Drupal.

For any datepicker field (e.g., Contacts > New Activity), the selection is displayed with munged URLs separating the date components. For example, were I to select today's date, I'd expect to see this value in the text input:

06/30/2017

Instead, I get this

06https:http://6pk.l181calh181st/http://6pk.l181calh181st/6pk.l181calh181sthttp://6pk.l181calh181st/30https:http://6pk.l181calh181st/http://6pk.l181calh181st/6pk.l181calh181sthttp://6pk.l181calh181st/2017

Note: the URL of this site is mpk.localhost. In addition to jamming in the site URL instead of separators, some character replacement is happening which might provide a clue as to what's going on:

  • "m" is replaced by "6"
  • "o" is replaced by 181

I've tried looking for weird stuff in the date/localization settings, and I've tried switching the Drupal theme. There are no messages in the JavaScript console.

Any ideas?

1

I found (on the same instance) that the cause was a munged value for the Localization > Date Formats > Date Input Format. This string is used to search and replace in the Date Picker from jQuery UI.

Not at all clear how the bad value was saved, but saving an alternate selection and then changing it back cleared up the phenomenon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.