1

When I am changing a query or logic in my hook, I have to reinstall the entire module so then only the updated logic / code works in civicrm.

Is there a settings to clear the cache or something

I tried the below options none works

1. Admin > System Settings > Cleanup Caches

2. http://localhost/drupal/civicrm/menu/rebuild&reset=1
0

Just go to http://localhost/drupal/civicrm/clearcache. This does a pretty thorough cache clear, including hooks.

  • Thanks for your answer; But it doesn't work for me; I have to reinstall my extension – ManiMuthuPandi Jul 6 '17 at 18:25
0

If you are using drupal CMS, then you would need to clear all drupal cache and that should fix the issue.

  • Thank you for your answer! Can you please expand with instructions on how to clear the caches that differ from what OP has already tried? It sounds like the OP is asking for that. – Christia Jan 3 '18 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.